1 Reply Latest reply on Sep 18, 2019 10:04 AM by droordaEPG

    Unable to Disable Hyperthreading for a VM

    droordaEPG Lurker

      I am trying to disable hyperthreading for a VM that has SQL. I used to be able to do this via GUI or powercli. I can no longer find the option the GUI(HTML5 or FLEX) and the powercli command does not seam to work.

      I am running Set-VMResourceConfiguration -HtCoreSharing None, but when I run Get-VMResourceConfiguration it still shows 'All'

      It seams that the command is silently failing or worse has been silently disabled.

       

      Does anyone have a suggestion on how to fix. Not disabling hyperthreading is not an option do to cost of cpu core licenses.

      I am running ESX 6.7

      I would rather not disable hyper threading for the physical host

        • 1. Re: Unable to Disable Hyperthreading for a VM
          droordaEPG Lurker

          I have received a reply from support. The ability to manage Hyper Threading on a per VM basis was silently removed in 6.5.

          This leaves a bug int he powercli that is not throwing an error when an attempt to make the change is made

          This means that hyper threading needs to be disabled on the cluster if you want to get full core performance from your SQL licensing. Leaving it on will mean that you may only get half the performance out of your SQL when using per core licensing.