2 Replies Latest reply on Sep 18, 2019 12:51 PM by chaimeisen

    Changing hardware compatibility

    ChaimE Novice

      I'm trying to run an old virtual machine, running Windows 98 Second Edition, which was created as a Workstation 5.x virtual machine, under VMware Workstation 15 Player (because I needed to install it on a new computer and I couldn't find an older version of VM Player to download). Apps keep becoming unresponsive and it keeps crashing. What can I do to improve system stability and responsiveness?

      On a related note, is there a way to change the hardware compatibility setting in VMware Workstation 15 Player (not Pro!)? Documentation at Configuring and Managing Virtual Machines instructs you: Select the virtual machine and select VM > Manage > Change Hardware Compatibility. However, I can't find any VM to select and altogether I can't find  any way to change hardware compatibility.

        • 1. Re: Changing hardware compatibility
          AlessandroRomeo68 Expert

          Hi,

           

          I had done something like this some time ago. I used vCenter Converter Standalone to recreate the virtual machine in a new virtual environment.

           

           

          https://my.vmware.com/web/vmware/details?downloadGroup=CONV62&productId=701&rPId=20180

           

          there are also previous versions.

           

          ARomeo

          1 person found this helpful
          • 2. Re: Changing hardware compatibility
            chaimeisen Lurker

            Hi ARomeo! Thank you very much for your reply! It definitely helped! It's weird that VMware doesn't document this excellent converter as a solution for a hardware compatibility problem. Anyway, I wish I could say that this solved my problem with running the virtual machine. I don't know if it's that the converter only enables me to convert the virtual machine from Workstation 5.x to Workstation 11.x (and not the currently available Workstation 15). That is an issue, although I doubt that explains my lingering issue.

             

            At issue is constant and ongoing problems of unresponsiveness and crashing that still plague the virtual machine since I switched to Workstation 15 Player, that the conversion hasn't solved. If anything, it's worse. Now, the Workstation Player seems to have lost the ability to run the virtual machine at all. When I try to play the virtual machine, I just get an endless "Waiting for connection" screen. After spending the past two days trying to get the virtual machine to work, I think I'm back to the drawing board!