0 Replies Latest reply on Sep 16, 2019 5:36 AM by PowerPlantTech

    "The VSS service is shutting down due to idle time out"

    PowerPlantTech Lurker

      I am experiencing the following errors with VEEAM Backup and Replication....only Backups....but for both TIER 0 and TIER 1.

       

      "An error occurred while quiescing the virtual machine."

      "Failed to create VM snapshot. Error: CreateSnapshot failed, vmRef vm-725, timeout 1800000, snName VEEAM BACKUP TEMPORARY SNAPSHOT, snDescription Please do not delete this snapshot. It is being used by Vrram Backup, memory False"

       

      Note that this occurs on about 1/3 of my VMs, but not the same one every day.

       

      I noticed the event log on one of the VMs states "The VSS service is shutting down due to idle time out"

       

      I consulted with VEEAM but they advised I should talk with VMWare.

       

      VEEAM: 9.5 U4 (9.5.4.2753)

      VMs: Windows Server 2012 64 bit

      VMWare Tools: Version 10287 (10.1.15) MSI installation

      EXSi: 6.5 (VM Version 13)

       

      This is what I have done:

      1

      Opened Disk Management and looked at the Volume Shadow Service tab:

      Every VM I looked at had it disabled....this includes VMs that had no errors with backup and replications. So I left that setting alone.

       

      2

      Noticed some VMs had a floppy drive attached (and an error in the event log associated to the floppy drive)...so I disabled the floppy drive

       

      3

      Looked at VMWare services in services.msc...the VMs all seem to match

       

      4

      Disabled Tier 1 and Tier 2....I still get Tier 0 quiescing errors when only Tier 0 is running

       

      5

      Found I was getting "The VSS service is shutting down due to idle time out" messages in the event logs

      I standardized the VSS setting in services.msc from Manual to Auto and ensured the service was started

       

      6

      Ran the vssadmin list writers command from the CMD window and found 3 VMs I have problems with did not have the BITS service running. I started the BITS service

       

      7

      Looked at the UUID attribute....I found it set the TRUE on one of the VMs with the quiescing error

       

      8

      services.msc Start Virtual Disk service

       

      9

      Checked disk partitions:

      Properties....look for Volume Shadow Service tab....enable if it is not

      Found no VM I looked at had VSS enabled...all were disabled including VMs that had not errors

       

      10

      In the event logs I do see:

      Lots of NTFS warnings and errors and

      Disk 1 has been surprized removed

      I am not sure if this plays a role

       

      11

      Per https://kb.vmware.com/s/article/2069952

      Disable the VMware Snapshot provider service in the guest operating system.

      Restart the Volume shadow copy service.

       

      I am out of ideas....any assistance would be appreciated!

       

      Thomas