4 Replies Latest reply on Sep 13, 2019 2:56 PM by TECH198

    Running Spinrite in VM RAW dsk access

    TECH198 Enthusiast

      It is a good way to do disk repair/savage data ?

       

      I followed this: - VMware Knowledge Base

       

      It seems to work well, even for Spinrite, but i'm wondering since it IS a pass-through file on the host, would that mean more problems over attaching directly inside a PC ? Or would the transation be the same ?

       

      eg... virtual disk <> raw file on host be an issue at all ??

       

      Has anyone does this method and worked just as well as  ? Unsure weather RAW (full device) access would itself intrude more problems.

       

      Update: For some reason have experienced errors in VM, 11.1.1,

       

      Update 2: When I "Continue, seems drive activity keeps going, but vm still stays frozen, so al i'm guessing is it stil working behind the scenes, it's just a visual issue.

      Screen Shot 2019-09-08 at 12.00.28 pm.png

        • 1. Re: Running Spinrite in VM RAW dsk access
          dlhotka Virtuoso

          Wow, spinrite, that's a blast from the past.  Modern hard drives have moved a long way from needing it - are you trying to recover an old disk? 

           

          I'd be surprised if it a) worked at all and b) worked properly through a VM.  It was designed to use direct low-level hardware access controls and did some pretty funky stuff - as I recall, it doesn't even work with a USB drive (needed a direct IDE connection).  If you really do need to run it, building a windows box is probably your best option.

          • 2. Re: Running Spinrite in VM RAW dsk access
            TECH198 Enthusiast

            Spinrte is still users on modern drives today. Although is limited in capacity to 2.2TB

             

            i know direct access is required, so i'm also assuming then, any "upset" by sticking RAW disk access from a VM in-beween to pass the geometry of a drive back and fourth between VM and attached drive, will cause issues.. at the end of the day..

             

            My question is just more about the visual side of it only..

             

            It seems the drive keeps going in the background, but the VM has issues,, (what issues specific i have no idea) but if makes it freeze. and errors.

             

            I'm guessing proving RAW disk access is only temporal as it *may*.,, never too be used as a permanent solution as i found out. Particularly if a tool needs physical access, but your trying to force it to use a "go-between" instead..

             

            Other non-dircct access tools may work just as well. but in this case the drive is blank, noting to loose.. Its just a case of testing to make sure the drive is ok  as we've found a few issues with reading when data was n their in the past...

            • 3. Re: Running Spinrite in VM RAW dsk access
              dlhotka Virtuoso

              As cheap as drives are these days, I just dispose of a drive as soon as it exhibits any signs of issues, but we'll save that for a conversation over an adult beverage :-).

               

              Raw disk access via a VM isn't the same as direct interface access via the IDE controller - I'd drop Steve a note and see if he's tested this scenario.  It may 'look' like it's working, but not really be doing anything, or doing exactly what's intended.  As far as the GUI goes, Spinrite was written in assembly language, so it may be using old/depreciated/unsupported functions to update the GUI interface, which the VM doesn't support.

              • 4. Re: Running Spinrite in VM RAW dsk access
                TECH198 Enthusiast

                I think its Fusion, as spinrite is ok on a psychical system

                 

                (umm.I also think I just answered my own question) ... I put it down to : "It will work, but not always well "because" of the pass through, and because of that file on the host, it would lag behind always, thus provoking the error in Fusion.."

                 

                Actually, any direct-access needed to a drive i'm guessing would cause problems when you have an additional 'layer'. in any case spinrite failed on physical system, beause the drive i was testng was 3TB in size.. Got an overflow error, so waiting for next release..