3 Replies Latest reply on Sep 2, 2019 8:26 AM by nickscarpenter

    VIO 5.1 - new deployment issues

    nickscarpenter Lurker

      Hi All

       

      I have deployed VIO 5.1.0.1 , but have found a couple of things that arnt working properly and am now stuck......

       

      I have however managed to create networks, create instances , upload and launch a windows server image etc.

       

      Problem 1 - updating to the latest 5.1.0.2 patch fails, runs for a fair amount of time then errors out "helpfully doesnt say much other than failed"

      Problem 2 - console to instances doesnt load "just get took too long to respond greyscreen when the console would be"

      Problem 3 - im also trying to integrate VIO for Kubernetes , when trying to create a new provider using Openstack , i cannot progress past the authentication screen

       

      im convinced issue 2 and 3 are realated to an issue with the "public ip assignment and service bindings" , i can ping the assigned public IP and resolve it via dns and can see traffic from the firewall to the server, i have tried creating and replacing the SSL certificates , but with no successs , i dont seem to be getting SSL either when using the internal ip , only listens on http

       

      Cheers

       

      Nick

        • 1. Re: VIO 5.1 - new deployment issues
          nickscarpenter Lurker

          running netstat from the controler node i can see that its listening on port 5000 on both the public and private ips

          • 2. Re: VIO 5.1 - new deployment issues
            nickscarpenter Lurker

            when trying to replace the certificate via CLI , i am now seeing the folowing issue ,

             

            /var/lib/vio/ansible/cert-update.yml failed on the following nodes: [u'10.0.0.50']vio

             

            looking at the ansible log file this is because of the folowing

             

            2019-09-02 14:45:31,786 column.plugins.callback.progress Started TASK [prep-lb : copy user provided certificate to our staging directory]

            2019-09-02 14:45:31,829 column.api.backend.cache.store Got key 011264f5-eba6-42b8-9cf1-2a5ea076bbe5 from store runs

            2019-09-02 14:45:31,830 werkzeug 127.0.0.1 - - [02/Sep/2019 14:45:31] "GET /runs/011264f5-eba6-42b8-9cf1-2a5ea076bbe5 HTTP/1.1" 200 -

            2019-09-02 14:45:31,851 p=1509 u=jarvis |  fatal: [10.0.0.50 -> localhost]: FAILED! => {"changed": false, "failed": true, "msg": "Unable to find 'vio.crt' in expected paths."}

            • 3. Re: VIO 5.1 - new deployment issues
              nickscarpenter Lurker

              fixed this , wasnt referencing the path correctyl , the task completed , however it hasnt solved my issues , nor does it appear to atcually have bound the certificate to the websites?