3 Replies Latest reply on Aug 26, 2019 11:31 PM by Ray_handels

    Provision app suspended in task manager - apps takes a minute to open

    dbrutus Novice

      Hello,

      Hopefully someone could help me. I recently finished creating and testing our brand new LTSC 2019 gold image with some standard apps installed. Everything works fine after doing about 2 months of testing. Today I setup the provisioning machine by cloning the gold image, uninstalling Appvol agent, UEM, uninstalling AV, and horizon agent. Once all uninstalled, I reinstalled the appvol agent (2.15). I started re-creating appstack which was previously on LTSB 2016. I installed a couple of apps and they all successfully opened on the provisioning machine.

       

      I then completed the installation process. I initially opened 2 out of the 3 apps and they opened fine but when I launched a 3rd app (STATA 16), it did not initially open. I thought maybe I did not double click on, so I clicked again, and nothing happened. I looked at the task manager and it said suspended next the STATA. It took about a minute for the app to launch. I tried the other apps which successfully launched, and they did the same as well. It took a minute for them to open and I also noticed it said suspended next to the app name in the task manager. I logged off and tried again and noticed the same after I open STATA16. The system became unstable because every app that I opened took a long time to launch and I also see a lot of spinning wheel with apps not responding.

       

      I tried a fresh install provisioning machine of LTSC 2019, and it did the same. Funny enough I do not experience the same problem with LTSB 2016 version of the appstack with the same apps installed. I have yet to rollback Windows update because the fresh installed had the latest Windows update just like my gold image and my previous LTSC 2019 provisioning machine. I will also try the latest appvolumes agent (2.17). I’m not sure if anyone has experienced this issue.

       

      Operating System: LTSC2019

      Vsphere: 6.7 U2

      Esxi: 6.7 U2

      Hardware Version: 15

      Appvolumes: 2.15

      Horizon View: 7.7

        • 1. Re: Provision app suspended in task manager - apps takes a minute to open
          Ray_handels Master
          vExpertCommunity Warriors

          To be honest no, I have not seen that message in the past.

          What you do see when using a very large application is that it could be that the application still needs to be reverse replicated.

          In the older version of Appvolumes all registry keys and files were merged during logon. You could however progress the logon by telling the Appvolumes agent to just release the logon. Downside of this behavior was that when you were logged in it was still processing the registry keys. If you did not force the logon to continue you had very long logon times (more than 4 minutes).

           

          In newer version they added reverse replicate which means as much as they postpone a part of the merging of the application until after logon. If you log on and almost instantly stat up the application it could be that not all registry keys are merged yet thus resulting in a large startup time of the application(s).

           

          What happens if you create a very small application like NotePad++??

          • 2. Re: Provision app suspended in task manager - apps takes a minute to open
            dbrutus Novice

            Hi Ray. It seems like there's a problem with the installation of STATA 16. I had an appstack which previously had STATA and all the apps launched fine but as soon as I installed STATA 16 the whole OS misbehaves. I created a small appstack with Putty and it worked fine. Created another appstack with Putty and the different apps and everything worked fine. As a last ditch effort, I installed STATA15 and STATA16 on the appstack and I did not experience any issues. Seems to be something with STATA 16.

             

            I forgot to mention that I'm testing this new version of my image with mandatory profile too.I'm seeing weird app issues with mandatory profile and appstack. One set up app works on one pool without mandatory profile but when I test the same appstack on a pool with mandatory profile, it throws all types of errors with those 2 particular apps.

             

            Anyone using mandatory profiles with appstacks?

            • 3. Re: Provision app suspended in task manager - apps takes a minute to open
              Ray_handels Master
              vExpertCommunity Warriors

              We did use mandatory profiles with appstacks without UEM but eventually ended up ditching the mandatory profiles because of issues with applications (one of them was Excel which is actually in the golden image) and because Microsoft does not really promote using mandatory profiles in W10. Logintimes are even quicker without mandatory profiles if you remove all unnecessary modern apps.