1 2 3 4 5 Previous Next 61 Replies Latest reply on Nov 12, 2019 5:38 PM by TimMann Go to original post
      • 30. Re: esxi cannot boot after updating to 6.7 u3! how to fix it?
        Lomotex Lurker

        Dear Tim,

         

        When will you provide an offical bugfix, this is my first install ever of ESXi 6.7u3 on a Lenovo ST550 (with the custom Lenovo image) and now this.

         

        Strangely it installed without any problems but then after about 5 reboots this error message appeared.

         

        The firmware probably had different page tables on this specific boot as you told, so ESXi failed to load this time.

         

        But wouldn't this also mean the odds are fifty-fifty that it will successfully boot with a cold restart?

        • 31. Re: esxi cannot boot after updating to 6.7 u3! how to fix it?
          TimMann Enthusiast
          VMware Employees

          > When will you provide an offical bugfix

           

          It ought to be fixed in the next regular patch release along the 6.7 line. I'm not allowed to give out details or dates for future releases. In the meantime we'll issue a KB article with the workarounds.

           

          > But wouldn't this also mean the odds are fifty-fifty that it will successfully boot with a cold restart?

           

          There's no reason it would be 50-50. From what we've seen so far, a few machines get the error every time, while most never do. Yours is the first machine I've heard of that gets the error sometimes but not always.

          • 32. Re: esxi cannot boot after updating to 6.7 u3! how to fix it?
            TheExpert Novice

            It ought to be fixed in the next regular patch release along the 6.7 line.

             

            Will then a new update-from-esxi6.7-6.7_update03.zip file be provided to come to the update 3 releases?

             

            Thank You.

            • 33. Re: esxi cannot boot after updating to 6.7 u3! how to fix it?
              TimMann Enthusiast
              VMware Employees

              It ought to be fixed in the next regular patch release along the 6.7 line.

               

              > Will then a new update-from-esxi6.7-6.7_update03.zip file be provided to come to the update 3 releases?

               

              I don't think so. I believe it will work to apply 6.7u3 *and* the subsequent patch (when the patch is released) without rebooting in between. I will check to be sure, though.

              • 34. Re: esxi cannot boot after updating to 6.7 u3! how to fix it?
                TimMann Enthusiast
                VMware Employees

                > I don't think so. I believe it will work to apply 6.7u3 *and* the subsequent patch (when the patch is released) without rebooting in between. I will check to be sure, though.

                 

                Yes, I checked with someone who's more familiar with the patch application process, and he said:

                 

                Customers who are in pre-67U3,

                    - They can apply 67 patch fix directly with patch deliverables via regular method of patching (release are cumulative and they will get all fixes of 67 U3 plus latest fix of patch).

                      We will test this path for sure during our patch testing.

                 

                Customers who are affected with UEFI boot issue on 67 U3 environments,

                    - They need to use workaround and they can directly apply the patch via regular deliverables.

                 

                • 35. Re: esxi cannot boot after updating to 6.7 u3! how to fix it?
                  ashleyw Hot Shot

                  We just went through this exact scenario ourselves. all our hosts (Cisco UCS B200-M4) were fine apart from an esxi host SuperMicro X9DR3-F we use for our backup layer. We have gone back to the last bootable image of 6.7 build 13981272 (using approach of booting from 6.7 update 2 boot media and repairing as described earlier) and things are luckily working again - we are still UFEI booting as before.

                  Will the notification of a re-released iso image update be via this forum or somewhere else?

                  I can imagine this to be a real pain for many shops using an assortment of current and old gen kit for virtualised backup/management hosts etc so it would be great if VMware can push an urgent fix.

                  • 36. Re: esxi cannot boot after updating to 6.7 u3! how to fix it?
                    TimMann Enthusiast
                    VMware Employees

                    If you need an urgent fix on supported hardware, please file an SR. Right now there is only a plan to get a fix into the next regular patch. Also there is not a plan to release an ISO with the next patch. Plans can be changed, but asking in the community forum isn't the most effective way to make that happen.

                     

                    Note: I'm an engineer working on new development on our main branch. I'm not responsible for patch and update release plans. The most I do on those is to backport my fixes from the main branch when needed.

                    1 person found this helpful
                    • 37. Re: esxi cannot boot after updating to 6.7 u3! how to fix it?
                      HaCKSchnitzel Lurker

                      i have managed to fix the boot issue within replacing the efi files after i have executed the update to U3. It states that is was successfully but after replacing the .EFI the version displayed to me is the previous one. -> 13981272

                      So is this now related to be display only or i am still not at the latest version? I used the esxcli to update. On all previous patches i had to apply this worked fine.

                       

                      • 38. Re: esxi cannot boot after updating to 6.7 u3! how to fix it?
                        AlexHautequest Novice

                        Thanks for all your notes and effort Tim, however I just want to add how very disappointing is finding out that Vmware, after knowing about it a month, is still issuing this buggy version out for their customer base. After the problem was discovered, next steps known and the internal team engaged to resolve it, this version should had been pulled off any list of available updates, saving their customers the hassle and trouble. Because they didn't, now there are hundreds of hosts dead, needing manual recovery, with the result of negligence and poor decision making. There is only so much the SR can do, and of course they are not going to touch each of our systems - so again, the ball is on us to make it right. Surely our account rep will be notified, as things escalated pretty high around.

                        1 person found this helpful
                        • 39. Re: esxi cannot boot after updating to 6.7 u3! how to fix it?
                          larsonreever Novice

                          I'm having the same issue in my home lab.  I   tried Legacy Only boot and updated bios while disabling UEFI 

                          so far it boots up from the fresh install and is working nicely. Maybe i'm going to update one esxi. Now its working fine for me .

                          • 40. Re: esxi cannot boot after updating to 6.7 u3! how to fix it?
                            alphons Lurker

                            Booted (bios legacy mode) and updated to U3 succesfully.

                             

                            Version: 6.7.0 Update 3 (Build 14320388)

                             

                            Reboot, set bios in UEFI mode, same Error (again)

                             

                            Reboot, set bios in Legacy mode, succes (6.7.0 Update 3 , Build 14320388)

                            ---

                             

                            We are one month away from the U3, in meantime no patches or fixes for booting in UEFI mode?

                             

                             

                             

                            • 41. Re: esxi cannot boot after updating to 6.7 u3! how to fix it?
                              VirDeVir Lurker

                              I have Asus P9D WS as my test lab server.

                              Booted (bios legacy mode) and updated to U3 successfully after updating bios to latest version 2402

                              • 42. Re: esxi cannot boot after updating to 6.7 u3! how to fix it?
                                eric87m Novice

                                Also just ran into this after a 6.7U1 to 6.7U3 update on a SuperMicro X9SCM-F motherboard. I just did a 6.7U2 update reinstall and bam, back in business. No extra steps needed.

                                • 43. Re: esxi cannot boot after updating to 6.7 u3! how to fix it?
                                  Protogen Novice

                                  Thank you TimMann.

                                   

                                  I have just successfully upgraded from 6.7 to 6.7u3 using your "Workaround option 2" (manually copying the 6.7u2 bootloader into the system partition to replace the 6.7u3 bootloader).  Followed your very good instructions - worked first time.  I am still booting UEFI on 6.7u3.

                                   

                                  Motherboard: Supermicro A2SDi-16C-HLN4F.

                                  • 44. Re: esxi cannot boot after updating to 6.7 u3! how to fix it?
                                    paulvill Lurker

                                    Hi all  , I've been having exactly this problem on my DELL E7440 Notebook , (I know is unsupported but it is used only to host a Lab). After initial Upgrade to 6.7 U3 it failed to boot with the same error. While using installation cd/usb it failed to load yellow boot screen with the same error (right after loading kernel modules).

                                     

                                    - disable UEFI / use only legacy boot (mandatory)

                                    - no need to disable VT-d After above system is able to load 6.7 U3 without any problems. Luckily my C240 M4 with UEFI for vSAN were not haviny any issues.

                                     

                                    [url=https://postimg.cc/bD7ZPS8M][img]https://i.postimg.cc/bD7ZPS8M/IMG-1327.jpg[/img][/url]

                                     

                                    Testing ESX 6.7 on my dell E7440 , changed Boot to legacy and worked perect , thanks for sharing !