5 Replies Latest reply on Aug 16, 2019 7:43 AM by shaggy_041086

    How to do REST calls on vRO 7.3

    shaggy_041086 Novice

      Hi all,

       

      I am new to REST so please bear with me. I have a workflow in vRO to check DEAD LUNs on my host HBAs and it sends an email report if it finds one. The workflow has only one input, i.e. "email id".

      When I try to execute the workflow in swagger page of vRO with following input -

      "parameters": [
          {
              "value": {
                  "string": {
                      "value": "XYZ@blahblah.com"
                  }
              },
              "type": "string",
              "name": "toAddress",
              "scope": "local"
          }
      ]

      , it says "400 – Bad Request : The server cannot or will not process the request due to something that is perceived to be a client error (e.g., malformed request syntax, invalid request message framing, or deceptive request routing)". But when I do GET commands, like GET all workflows and EXECUTIONS, it works fine.

      I even tried Postman and it also works with Basic authentication, but only GET commands. It throws same error as above when trying POST. Tried using Oauth 2.0 in Postman as mentioned here. But not able to get the {{client-id}} info that is required there.

      Now I am trying to execute the POST command through Powershell, but since vRO uses holder-of-key (HoK) token system to get me authenticated through SSO, I am not sure basic authentication would work or how to go about using that kind of authentication.

      Anyone had similar issues? Fixes? Recommendations?

      What client do you all use to do REST calls to vRO? This particular post says POST method is possible through basic authentication, but is not working for me. I have used admin credentials to vRO and have confirmed I have admin rights.