5 Replies Latest reply on Aug 16, 2019 5:14 AM by a.p.

    ESXi/vCenter 6.7u2 storage vMotion completed but old datastore still shows VM (verified no ISO or snapshots)

    MikeMedcalf Lurker

      I recently migrated a VM from one datastore to another.  vMotion completed successfully and without error and the settings on the VM only reference the new datastore.  Looking at the file structure of the old datastore, there is only the .sdd.sf and .vSphere-HA folders and no files on root.  However, when I look at attached VMs on that datastore it still shows the migrated Virtual Machine.

       

      I've been digging through forums for the last couple of hours but everything similar suggests a connected ISO, old snapshots, or a failed/corrupt migration.  Neither exist or existed prior to the migration, the migration was successful, and no errors were generated (at least as per the GUI).  For good measure I've also tried vMotion'ing the server to yet another datastore along with another host but to no avail.  As a final desperation I tried connecting/removing an ISO to see if an old link reference existed but this also had no impact.  All this said, if I missed a good reference please let me know!

       

      This is all part of a grander project.  We are migrating from a 5.5 environment to a new 6.7u2 environment (new hosts and vCenter deploy, offline moves) then migrating to new storage.  There are actually two servers that did this out of 10 that were migrated during the same approx. time frame and are the only ones out of ~50 servers migrated so far.  If I can provide more specific information, logs, and/or screenshots, I'm happy to attach it.

       

      Thanks!