1 Reply Latest reply on Aug 19, 2019 3:12 AM by TheOnionMaster

    InteractiveToolsAreReady are always false, even though I'm logged in via GUI

    TheOnionMaster Lurker

      Hi guys,

       

      I got a problem regarding the vSphere API and I already asked for help @ interactiveSession=True mode produces a lot of problems · Issue #820 · vmware/pyvmomi · GitHub , but sadly my problem couldn't be solved yet. So I try my luck in the official forums and hope for support here.

       

      Short recap of what problem I fight with:

       

      I've got an installer, that I can't install with interactiveSession set as False, as it just returns something like ...non-zero exit code: 1 without any further explanation why though (maybe someone could help me with this problem as this would made the other problem obsolete), whenever I try to execute it with the RunProgramInGuest call. I tried to find out why that happens though for a good amount of time, yet didn't find out why I can't install it and why there is no real error message...

       

      So I had to find a workaround: set the interactiveSession as True and login to the VM before via GUI, to get the interactiveToolsAreReady to be True. That worked great for every client side Windows system like Windows 7, 8, 8.1 and 10. But not with the server side Windows systems like Windows 2012, 2016 and 2019 as interactiveToolsAreReady is always False - and yes, they got a GUI and also I also logged in there manually. Nothing worked. I never got the interactiveToolsAreReady to become True for those server machines.

       

      I would highly appreciate any kind of help, as this would fix a lot headache I've got right now...


      With best wishes,
      TheOnionMaster