3 Replies Latest reply on Aug 14, 2019 12:15 AM by VitthalMahale

    Unable to run Plugin Seed -1.0.0 project

    VitthalMahale Lurker

      1. I have downloaded the 'plugin seed -1.0.0'  project and run npm install command. I got the following result.

       

      npm notice created a lockfile as package-lock.json. You should commit this file.

      npm WARN @clr/angular@0.11.34 requires a peer of @angular/common@^5.0.0 but none is installed. You must install peer dependencies yourself.

      npm WARN @clr/angular@0.11.34 requires a peer of @angular/compiler@^5.0.0 but none is installed. You must install peer dependencies yourself.

      npm WARN @clr/angular@0.11.34 requires a peer of @angular/core@^5.0.0 but none is installed. You must install peer dependencies yourself.

      npm WARN @clr/angular@0.11.34 requires a peer of @angular/forms@^5.0.0 but none is installed. You must install peer dependencies yourself.

      npm WARN @clr/angular@0.11.34 requires a peer of @angular/platform-browser@^5.0.0 but none is installed. You must install peer dependencies yourself.

      npm WARN @clr/angular@0.11.34 requires a peer of @angular/platform-browser-dynamic@^5.0.0 but none is installed. You must install peer dependencies yourself.

      npm WARN @clr/angular@0.11.34 requires a peer of @angular/router@^5.0.0 but none is installed. You must install peer dependencies yourself.

      npm WARN ajv-keywords@3.4.1 requires a peer of ajv@^6.9.1 but none is installed. You must install peer dependencies yourself.

      npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.9 (node_modules\fsevents):

      npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.9: wanted {"os":"darwin","arch":"any"} (current: {"os":"win32","arch":"x64"})

       

       

      added 1338 packages from 1429 contributors and audited 36537 packages in 1023.054s

      found 14 vulnerabilities (3 low, 6 moderate, 5 high)

        run `npm audit fix` to fix them, or `npm audit` for details

       

      2. After run command 'npm audit fix (--force)' I got following result

       

      npm WARN @clr/angular@0.11.34 requires a peer of @angular/common@^5.0.0 but none is installed. You must install peer dependencies yourself.

      npm WARN @clr/angular@0.11.34 requires a peer of @angular/compiler@^5.0.0 but none is installed. You must install peer dependencies yourself.

      npm WARN @clr/angular@0.11.34 requires a peer of @angular/core@^5.0.0 but none is installed. You must install peer dependencies yourself.

      npm WARN @clr/angular@0.11.34 requires a peer of @angular/forms@^5.0.0 but none is installed. You must install peer dependencies yourself.

      npm WARN @clr/angular@0.11.34 requires a peer of @angular/platform-browser@^5.0.0 but none is installed. You must install peer dependencies yourself.

      npm WARN @clr/angular@0.11.34 requires a peer of @angular/platform-browser-dynamic@^5.0.0 but none is installed. You must install peer dependencies yourself.

      npm WARN @clr/angular@0.11.34 requires a peer of @angular/router@^5.0.0 but none is installed. You must install peer dependencies yourself.

      npm WARN ajv-keywords@3.4.1 requires a peer of ajv@^6.9.1 but none is installed. You must install peer dependencies yourself.

      npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.9 (node_modules\fsevents):

      npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.9: wanted {"os":"darwin","arch":"any"} (current: {"os":"win32","arch":"x64"})

       

       

      up to date in 15.728s

      fixed 0 of 14 vulnerabilities in 36537 scanned packages

        7 vulnerabilities required manual review and could not be updated

        3 package updates for 7 vulnerabilities involved breaking changes

        (use `npm audit fix --force` to install breaking changes; or refer to `npm audit` for steps to fix these manually)

       

       

      3. After run command 'npm start' its  following error

       

       

       

       

      > ng serve --port 4201 --proxy-config proxy.conf.json

       

       

      ** Angular Live Development Server is listening on localhost:4201, open your browser on http://localhost:4201/ **

      10% building modules 6/6 modules 0 activei 「wds」: Project is running at http://localhost:4201/

      i 「wds」: webpack output is served from /

      i 「wds」: 404s will fallback to //index.html

      Date: 2019-08-12T07:25:43.361Z

      Hash: 2f90f92b4998e7fedda3

      Time: 8418ms

      chunk {main} main.js, main.js.map (main) 354 kB [entry] [rendered]

      chunk {polyfills} polyfills.js, polyfills.js.map (polyfills) 354 kB [entry] [rendered]

      chunk {runtime} runtime.js, runtime.js.map (runtime) 5.22 kB [entry] [rendered]

      chunk {scripts} scripts.js, scripts.js.map (scripts) 558 kB  [rendered]

      chunk {styles} styles.js, styles.js.map (styles) 776 kB [entry] [rendered]

      chunk {vendor} vendor.js, vendor.js.map (vendor) 5.5 kB [initial] [rendered]

       

       

      ERROR in node_modules/rxjs/internal/types.d.ts(81,44): error TS1005: ';' expected.

      node_modules/rxjs/internal/types.d.ts(81,74): error TS1005: ';' expected.

      node_modules/rxjs/internal/types.d.ts(81,77): error TS1109: Expression expected.

      node_modules/rxjs/internal/types.d.ts(82,52): error TS1005: ';' expected.

      node_modules/rxjs/internal/types.d.ts(82,88): error TS1005: ';' expected.

      node_modules/rxjs/internal/types.d.ts(82,92): error TS1109: Expression expected.

       

      Please help me to resove the issue. please go through the my current angular setup environment details.

       

         _                      _                 ____ _     ___

          / \   _ __   __ _ _   _| | __ _ _ __     / ___| |   |_ _|

         / △ \ | '_ \ / _` | | | | |/ _` | '__|   | |   | |    | |

        / ___ \| | | | (_| | |_| | | (_| | |      | |___| |___ | |

      /_/   \_\_| |_|\__, |\__,_|_|\__,_|_|       \____|_____|___|

                      |___/

       

       

       

       

      Angular CLI: 6.0.8

      Node: 10.16.2

      OS: win32 x64

      Angular: 6.1.10

      ... animations, common, compiler, compiler-cli, core, forms

      ... http, platform-browser, platform-browser-dynamic

      ... platform-server, router

       

       

      Package                           Version

      -----------------------------------------------------------

      @angular-devkit/architect         0.6.8

      @angular-devkit/build-angular     0.6.8

      @angular-devkit/build-optimizer   0.6.8

      @angular-devkit/core              0.6.8

      @angular-devkit/schematics        0.6.8

      @angular/cli                      6.0.8

      @angular/tsc-wrapped              4.4.6

      @ngtools/webpack                  6.0.8

      @schematics/angular               0.6.8

      @schematics/update                0.6.8

      rxjs                              6.5.2

      typescript                        2.7.2

      webpack                           4.8.3