0 Replies Latest reply on Aug 2, 2019 7:31 AM by DanVM99

    Office 2019 Skype for Business Address Book Search Broken with AppVols

    DanVM99 Novice

      Rather a strange/annoying issue this one......

       

      Recently it was discovered that the Skype for Business address book search was not working in our latest Windows 10 1903 VDI desktop pool.

       

      Initially it was thought that a change we made in our gold image was the cause.  The address book search was working perfectly while we were using Office 2019 (with Visio Standard) 64 bit. We later uninstalled the 64bit edition and installed the 32 bit version of Office 2019 (for compatibility reasons) and to be in keeping with our intended physical desktop rollout. While it is definitely a factor, it is not the whole story.

       

      After a bit of investigation the issue seems to arise when any AppStack is attached.  NOTE: AppStacks are assigned to the user not the computer.

       

      If the user has no App Stacks assigned or the App Volumes Agent is uninstalled, then the contacts search works as expected.

       

      My guess is some kind of snapvol.cfg configuration needs to happen but that is beyond my expertise with App Volumes.  I've had a look in the snapvol.cfg and compared registry and file locations for the respective 64 and 32 bit installations of Office 2019 and they all seem to point to locations that are the same regardless of 64/32 bit version.

       

      Obviously I understand that this may not be something a lot of people can test as you will require a functioning Skype infrastructure in order to test the address book search functionality works so any suggestions (apart from going back to the 64bit version of Office!) would be welcome.

       

      Visio seems to play no part in the issue as uninstalling it and testing again revealed the same problem.  We also tried removing Office from the capture machine and recaptured an app, which we then used as a test deploying it to our VM, but the issue persisted.

       

      I've included some brief information below which I think is relevant but if there is anything else you need to know, feel free to ask.

       

      Tests can be carried out against the Gold Image.

       

       

      Gold Image configuration

       

      O/S Windows 10 1903 64 bit

      Installed Apps   Office 2019 Pro Plus VL 32 bit

       

      App Volumes configuration

       

      Version 2.16

      Template 2.16

      Capture VM      Clone of Gold Image

      Changes snapvol.cfg entries tried

       

      exclude_path=\Program Files (x86)\Microsoft Office\PackageManifests

      exclude_path=\Program Files (x86)\Microsoft Office\root

      exclude_path=\Program Files (x86)\Microsoft Office\AppXManifest.xml

      exclude_path=\Program Files (x86)\Microsoft Office\Updates

      exclude_path=\Program Files\Common Files\Microsoft Shared\ClickToRun

       

      exclude_registry=\REGISTRY\MACHINE\SOFTWARE\Microsoft\Office\ClickToRun\REGISTRY < this was already added to the template to fix an issue with Visio loading slowly when AppStacks are attached.