6 Replies Latest reply on Jul 24, 2019 4:22 AM by cyberpaul

    Backup Problem ESXi

    stefa1991 Lurker

      Hi, I' m using Thinware vBackup software to make backup of VMs running on an ESXi 6.0 Server ( free ESXi with free license). I' m aware that ESXi free doesn't let make backups of VMs bacuse of the VAPD api, so i' m using Thinware vBackup software that can take full image backups of VMs on free ESXi using SSH( enabled on the ESXi server).

      Thinware vBack relies on VMWare VDDK to manipulate .vmdk files, so i' im using VDDK version 5.5.4 with it.

      The backup destination is a NAS on local network that has ext4 file system and 2 TB capacity.

      When i try to do any backup of VMs to the NAS i get the error:


            [NFC ERROR] Failed to create disk \\DATASHARE\mnt\HD\HD_a2\BackupOVH\ub01\190705_083956\ub01.vmdk: The destination file system does not support large files (12).



            [NFC ERROR] NfcFile_Open: Open failed:



            [NFC ERROR] NfcReceiveFile: failed to open file



            Failed to convert disk: The operation completed successfully (0xa00004650).



      But, the NAS already has large files stored in it( example some files over 10 GB each) and plenty of free space, so i don't understand why i get this error about large files support.

      The NAS is mounted via NFS.


      Can anyone help me?



        • 1. Re: Backup Problem ESXi
          daphnissov Guru
          Community WarriorsvExpert

          So you're having problems with free backup software of your free ESXi and want free help with it. Got it.


          Has this worked at all ever or no? What is the size of the VM you're trying to protect?

          • 2. Re: Backup Problem ESXi
            stefa1991 Lurker

            If the backup destination is set on local hard drive it works perfectly, i have tried to backup a 10 GB VM and it's ok, the problem is when i select the NAS as backup destination.

            • 3. Re: Backup Problem ESXi
              daphnissov Guru
              vExpertCommunity Warriors

              This NAS is presented to the ESXi host? If so, can you create any files whatsoever from the ESXi host on this export?

              • 4. Re: Backup Problem ESXi
                stefa1991 Lurker

                The NAS is not registered as a datastore to the ESXi host, but inside the VM (Win server 2012) where is installed the backup software i can see the nas as a network NFS share, so in backup configuration I set as destination, the path to the NAS.


                NAS is a dlink dns 320L

                • 5. Re: Backup Problem ESXi
                  daphnissov Guru
                  Community WarriorsvExpert

                  Don't know anything about this application or how it works, but it sounds like a problem with your NFS export configuration. You're better off seeing if you can get help from the vendor...for free.

                  • 6. Re: Backup Problem ESXi
                    cyberpaul Hot Shot



                    the error is due to overly eager VDDK checks before creating large virtual disks. They sometimes result in false positives.


                    You may try to:

                    - change file system on the NAS side

                    - use a newer version of VDDK


                    I'm not very familiar with Thinware vBackup, but in my environment I get good results with VDDK 5.5.5 and 6.5.2. I haven't had the time to test newer releases. VDDK is under rapid development which means you really have to test thoroughly.


                    Let us know if you managed to resolve the issue!