9 Replies Latest reply on Feb 17, 2020 3:23 AM by chunpingTian

    Host Esxi 6.0 (Not responding)

    Dreher_Bonfim Lurker

      Friends,

      I have a problem with a host in my environment, it appeared "not responding", I tried to reconnect and I did not succeed, I rebooted the hostd and vpxa service and it also had no effect, I can do ssh on the host and the VMs on it are all accessible and operational , the problem is only on the host that I can not reconnect it to vcenter, the error message is of time out ....

       

      Note: I CAN NOT RESET THE HOST, VMS CRITICS !!!

        • 1. Re: Host Esxi 6.0 (Not responding)
          RajeevVCP4 Hot Shot
          vExpert

          What is meaning of (I rebooted the hostd and vpxa service )

           

          did you restart these services ?

           

          are you able connect by DCUI ?

           

          if yes run below command

           

          1. Run this command to stop the smartd service:

            /etc/init.d/smartd stop

          2. Run this command to stop the smartd service from starting on reboot:

            chkconfig smartd off
          • 2. Re: Host Esxi 6.0 (Not responding)
            Dreher_Bonfim Lurker

            This restart will not disable VMs ???

            • 4. Re: Host Esxi 6.0 (Not responding)
              Dreher_Bonfim Lurker

              There was a change in the DNS structure, I found the problem, I changed the DNS and it worked!
              Thank you.

              • 6. Re: Host Esxi 6.0 (Not responding)
                chunpingTian Lurker

                Sorry, I may have the same problem. There are a lot of H: 0x0 D: 0x2 P: 0x0 valid sense data: 0x5 0x20 0x0 in the vmkernel log of esxi

                Can you tell me why you want to disable smartd?

                • 7. Re: Host Esxi 6.0 (Not responding)
                  Amin Masoudifard Expert

                  When you said the VMs are up and run, and only the ESXi is not responsible, it seems you joined your hosts with DNS names instead of IP addresses to the vCenter. Whatever you joined them to AD, or create an A (host) records to add them in the virtual datacenter, When the DNS is not responding to the name resolution process, the vCenter server or other solutions (like Backup server) that want to check the ESXi host or send any network traffic to it, then it couldn't find them in the naming query operation. So you will see a connection failure that prompt the host is not responding, while it's alive and really operational. In most of times it happened when the DNS server (that is responsible for vCenter server) is one of the VMs in that virtual environment, and maybe encountered with any type of failures (service, guest OS or failed in migration process or something like that). So you need to keep it alive always (24*7) because the vCenter use it for naming resolution, it's now one of your critical services.

                  Please mark my comment as the Correct Answer if this solution resolved your problem
                  • 8. Re: Host Esxi 6.0 (Not responding)
                    RajeevVCP4 Hot Shot
                    vExpert

                    You required to check hostd.log , in vmkernel try to find APD and PDL

                    about this sense code no issue from host side, is this issue occurred when backup initiated ?

                     

                    ypeCodeNameDescription
                    Host Status[0x0]OKThis status is returned when there is no error on the host side. This is when you will see if there is a status for a Device or Plugin. It is also when you will see Valid sense data instead of Possible sense Data.
                    Device Status[0x2]CHECK_CONDITIONThis status is returned when a command fails for a specific reason. When a CHECK CONDITION is received, the ESX storage stack will send out a SCSI command 0x3 (REQUEST SENSE) in order to get the SCSI sense data (Sense Key, Additional Sense Code, ASC Qualifier, and other bits). The sense data is listed after Valid sense data in the order of Sense Key, Additional Sense Code, and ASC Qualifier.
                    Plugin Status[0x0]GOODNo error. (ESXi 5.x / 6.x only)
                    Sense Key[0x5]ILLEGAL REQUEST
                    Additional Sense Data20/20Additional Sense Data unknown.
                    • 9. Re: Host Esxi 6.0 (Not responding)
                      chunpingTian Lurker

                      Hi,Rajeev:

                            I suspect the reason is that the inventory of the vCenter and esxi do not match, resulting in no response from the esxi host, but now I cannot get the vCenter logs and have no way to determine the specific reason

                           At the same time, I can be sure that this code is not the cause of the problem, because I no longer found any information about APD and PDL in hostd.log/vpxa.log/vmkernel.log.

                           And the problem with the host not responding has been fixed by removing the host and add the host.

                       

                      Thanks for your help.

                       

                      And :

                      Additional Sense Data20/00Unknown command options