2 Replies Latest reply on Jun 27, 2019 7:20 AM by kopseng

    Auto-mounted shares feature for Ubuntu guest is broken

    kopseng Novice

      I've googled through so many suggestions (both on this forum, blogs and stack exchange sites) for fixing this, but I cannot seem to conclude with anything else than this feature being utterly broken. People come up with manual workarounds where you manually mount the shares after boot, but I don't want workaround: I want the software I payed hundreds of euros for to work! That's why I don't use VirtualBox.

       

      Today I have (yet again) wasted well over an hour doing

      - reinstalling `open-vm-tools`

      - reinstalling `open-vm-tools-desktop` (which according to an Ubuntu bug is where the actual fuse module for hgfs is located)

      - reinstalling VMWare Tools (both with the above two packages removed, as well as when they are present, rebooting between every test)

       

      While "everything else" works, auto-mounting of shares does not, even though the shares are visible:

       

      $ vmware-hgfsclient

      SharedDocuments

      SharedDownloads

      Desktop

       

      P.S. Why do we get all this WYSIWYG crap that can't even format code, when all people need is the option of inputting Markdown triple quotes? #enterprise

       

      ubuntu 18.10

      open-vm-tools

      ubuntu 18.04

      ubuntu-guest

      windows-host

        • 1. Re: Auto-mounted shares feature for Ubuntu guest is broken
          continuum Guru
          Community WarriorsvExpert

          > but I cannot seem to conclude with anything else than this feature being utterly broken.

          I agree - that is the reason why you find those workarounds - I use cifs or sshfs.

          Dont hold your breath waiting for a fix.

          • 2. Re: Auto-mounted shares feature for Ubuntu guest is broken
            kopseng Novice

            It's a little troubling that I post an answer to this without being totally sure exactly all of the crucial steps for getting this working, but it seems to me that the essential bit that stopped this from working was a missing directory for the mount point. I found this out by seeing after a reboot that it suddently started working! Not as earlier, though, but still: without me doing anything all the shares had been mounted under /mnt/hgfs. That directory was added by me yesterday when trying out manually mounting the directory, and coincidentally, this is the same directory the `vmware-tools` init script tries to mount the shares at!

             

            I found this by grepping `/etc` for the mount point after seeing it was mounted, finding the /etc/init.d/vmware-tools.

             

            It might not be everything you need to get it working, possibly needing to either reinstall open-vm-tools or VMWare Tools first, but still worth a try.