9 Replies Latest reply on Jul 15, 2019 2:34 PM by balawiz

    vRA 7.6 Upgrade from 7.2 Pre install script error

    balawiz Novice

      The vRA7.2 minimal environment upgrade to 7.6 fails in the pre install script check with the following error to IaaS windows machine ( hosted with all the vRA components like DEM, Manager, Agent etc).

       

      (15047) Applying automatic fix for PowerShellScriptExecution prerequisite failed.

      (15005) Applying automatic fix for IISServer prerequisite failed.

       

      Steps followed:

      -> Powershell execution is updated in gpedit.msc

      -> Management agent Service account is part of Administrators group and IIS App pools are configured with same service account

      -> Restarted IaaS server and as well as installation, but same error. Also, firewall is disabled in IaaS server

       

      Below is command logs from IaaS server

       

       

      [UTC:2019-06-22 19:14:38 Local:2019-06-22 12:14:38] [run-prereq] Applying automatic fix for PowerShellScriptExecution prerequisite (Check that Group Policy enable PowerShell script execution) failed. Error: Disabled

      Resolution: Group Policy should enable PowerShell script execution.

       

      UTC:2019-06-22 19:14:38 Local:2019-06-22 12:14:38] [run-prereq] ERROR: Security error. Details: System.Security.SecurityException: Security error.

         at System.Management.Automation.MshCommandRuntime.ThrowTerminatingError(ErrorRecord errorRecord)

      The Zone of the assembly that failed was:

      MyComputer

      [UTC:2019-06-22 19:14:38 Local:2019-06-22 12:14:38] [run-prereq] ERROR: Security error. Details: System.Security.SecurityException: Security error.

         at System.Management.Automation.MshCommandRuntime.ThrowTerminatingError(ErrorRecord errorRecord)

      The Zone of the assembly that failed was:

      MyComputer

      [UTC:2019-06-22 19:14:38 Local:2019-06-22 12:14:38] [run-prereq] ERROR: Applying automatic fix for IISServer prerequisite (IIS Server) failed. Error: Error while applying fix for IISServer:

      Security error.

      Security error.

       

      From IaaS server All log

      [UTC:2019-06-22 19:18:59 Local:2019-06-22 12:18:59] [VMware.Cafe]: [sub-thread-Id="9"  context=""  token=""] (5638) GET config/nodes/7953ABB0-F4D5-......./commands/next-command

      [UTC:2019-06-22 19:19:00 Local:2019-06-22 12:19:00] [VMware.Cafe]: [sub-thread-Id="22"  context=""  token=""] (5638) Response: NotFound(404) 0:00.290

       

      Any help appreciated