1 2 Previous Next 15 Replies Latest reply on Aug 21, 2019 1:02 PM by bwinkler999

    "VCSA.SERVERNAME  could not be converged."

    BHagenSPI Enthusiast

      I'm running a VCSA with an external PSC (see specs at bottom of this post), and trying to "converge to embedded" via the web client; it fails after a few minutes with "VCSA.SERVERNAME could not be converged." (Replace "VCSA.SERVERNAME" with the name of our vcsa server, of course.)

       

      Actually, yesterday it *started* to run. It said something about passing the pre-checks, but then got stuck at 8% for over an hour. I finally rebooted both the vcsa and the psc. Ran the convergence again, got the above error.

       

      So I upgraded both vcsa and psc from 6.7.0.30000 to .31100 and tried the convergence again today; still get the above error.

       

      Today I look in /var/log/vmware/converge at the converge.log, and the date is yesterday. I ran the convergence 3 or 4 different times, but this file never updates. I open the .log and the last lines say:

       

      2019-06-19T19:33:30.652Z INFO converge Setting the converge running flag

      2019-06-19T19:33:30.665Z INFO converge Running converge on Management node.

      2019-06-19T19:33:30.666Z INFO converge Executing reconfiguring steps. This will take few minutes to complete.

      Please wait ...

      2019-06-19T19:33:30.666Z INFO converge Downloading RPMs

      2019-06-19T19:33:30.666Z INFO converge Collected client:rest as a part of Telemetry

      2019-06-19T19:33:30.731Z INFO converge Custom URL repositry not configured.Use default VMware repository URL.

      2019-06-19T19:33:30.731Z INFO converge  currentURL = https://vapp-updates.vmware.com/vai-catalog/valm/vmw/647ee3fc-e6c6-4b06-9dc2-f295d12d135c/6.0.0.30100.latest/

      2019-06-19T19:33:30.731Z INFO converge Manifest file = https://vapp-updates.vmware.com/vai-catalog/valm/vmw/647ee3fc-e6c6-4b06-9dc2-f295d12d135c/6.0.0.30100.latest/manifest/manifest-latest.xml

       

      The only file in that folder that gets updated is the "converge_rest.log" file...here are the last lines in it:

      2019-06-20 18:47:15,128 - vcenter.system_config_impl - INFO - feature ConvergeAPI is enabled.

      2019-06-20 18:47:15,128 - vcenter.system_config_impl - INFO - feature ConvergeAPI is enabled.

      2019-06-20 18:47:15,128 - vcenter.system_config_impl - INFO - feature ConvergeAPI is enabled.

      2019-06-20 18:47:15,128 - vcenter.system_config_impl - INFO - feature ConvergeAPI is enabled.

      2019-06-20 18:47:15,128 - vcenter.system_config_impl - ERROR - Converge is already running.Got another REST call externally.

      2019-06-20 18:47:15,128 - vcenter.system_config_impl - ERROR - Converge is already running.Got another REST call externally.

      2019-06-20 18:47:15,128 - vcenter.system_config_impl - ERROR - Converge is already running.Got another REST call externally.

      2019-06-20 18:47:15,128 - vcenter.system_config_impl - ERROR - Converge is already running.Got another REST call externally.

       

      Any help would be great!

       

      Here are the specs of my system:

       

      Vsphere: 6.7U1

      VCSA:

      Type: vCenter Server with an external Platform Services Controller

      Product: VMware vCenter Server Appliance

      Version: 6.7.0.31100

      Build number 13843380

      PSC:

      Type: VMware Platform Services Controller

      Product: VMware vCenter Server Appliance

      Version: 6.7.0.31100

      Build number 13843380

        1 2 Previous Next