6 Replies Latest reply on Jun 21, 2019 8:01 AM by ashsevenuk80

    UEM NoAD Mode

    ashsevenuk80 Novice

      Hi,

       

      My Setup

       

      Windows 10 Master image with Horizon and UEM NoAD mode agent installed.

      UEM server/File server - UEM manager installed, Folder redirection set to UEMProfiles which is a file share on the UEM server.

       

      Every time my users login to there VDI session the profile is not getting redirected to the path defined in the NoAD.xml and UEM Console\ folder redirection, the NoAD mode xml is in the ....\UEMCONFIG\general\flexRepository\NoAD

       

      Every time they login they get a temp profile, i've gon in and deleted the use of the temp, still no luck

       

      When i click on VMware UEM self support on the master image i get the error "Invalid Flex Profile group policy config: Flex config files path and profile archive path must be configured"

       

      where do i check the registry for the noAD config?

        • 1. Re: UEM NoAD Mode
          mchadwick19 Hot Shot

          Have you verified that your agent was installed properly in NoAD mode using the install command from here Install User Environment Manager in NoAD Mode (this is for 9.2, its still the same in 9.7).

           

          from @vJoeG 's response hereHow to configure NoAD Mode in UEM ?

           

          You should see a value for "msiNOADCONFIGFILEPATH" in HKLM\Software\VMware, Inc.\VMware UEM\

           

          Also check the InstallUEM.log file as well.

           

          EDIT: You mention you're users are getting temp profiles. Do you have persona or another roaming profile like utility running? Or a mandatory profile? UEM comes in after the user profile has been loaded. If your users are getting temp profiles there is an issue prior to UEM coming into play (I would assume).

          • 2. Re: UEM NoAD Mode
            ashsevenuk80 Novice

            Where and how do i pull the InstallUEM.logs?

            are there any user logs?

            • 3. Re: UEM NoAD Mode
              mchadwick19 Hot Shot

              The InstallUEM.log will be at the location specified in the install string. Which is usually the directory that the UEM.msi exists.

               

              User logs will be on the UEM File Server under each of your user's profile directory. You can add a text file called "flexdebug.txt" which will trigger the agent to log at a debug level.

              • 4. Re: UEM NoAD Mode
                ashsevenuk80 Novice

                So, i'm not going to have user logs because the profiles section isn't working, users profile creation redirection isnt working.

                do i add the flexdebig.txt to the NoAD.xml?

                InstallUEM.logs are these logs for the install of the agent or UEM management console?

                i've had a look in both directories and cant see them

                • 5. Re: UEM NoAD Mode
                  mchadwick19 Hot Shot

                  So if you followed the install string I linked in my first response you will have a InstallUEM.log file in the directory that the UEMAgent installer was executed from.

                   

                  From what it sounds like is your NoAD agent install was not installed correctly. My recommendation would be to uninstall the UEM agent and try to reinstall it following these instructions:

                   

                  1) Create a directory on your gold image/template in C:\ (I usually use C:\Agents and hide the folder) and copy the Agent MSI to that directory.

                  2) Open command prompt, cd to that folder, and run:

                       msiexec.exe /i "<UEMAgent.msi>" /qn LICENSEFILE="\\server\share\VMware UEM.lic" /l* InstallUEM.log NOADCONFIGFILEPATH=\\UEMserver.local\UemConfig$\General

                       2a) I usually put the license file in the root of the UemConfig$ share for easy access.

                  3) Wait 15 - 30 seconds.

                  4) Check the InstallUEM.log file in C:\<Folder>\ and check if the last line says "User Environment Manager -- Installed Successfully"

                  5) Double check that the registry settings are properly set as well.

                   

                  If it's anything other than that your file server permissions may be incorrect.

                  • 6. Re: UEM NoAD Mode
                    ashsevenuk80 Novice

                    It turns out the quotes used in the .XML file were different. Who would have guessed

                     

                    Thank you for your help mchadwick19

                    1 person found this helpful