1 2 3 Previous Next 41 Replies Latest reply on Aug 20, 2020 3:48 AM by capvar

    USB Device Causing VM's to Freeze - Cannot Kill vmware-vmx.exe

    MB1980 Lurker



      I'm having an intermittent issue when attaching Huawei mifi devices to my Windows 7 VM's
      using Vmware Workstation 15.


      Most of time it works fine and the mifi device appears and works with the vm, other times the vm
      freezes and cannot be shutdown via the vmware workstation menu.


      The only way I've been able to free up the vm again is to restart the host, which is a pain to do
      several times a day as I have a host of apps and other vm's working fine.


      I have several mifi devices and they all seem to work ok most of the time with the vm's, but
      they've all caused the crash at some point. I've tried using different USB
      Ports on the PC and a TPLINK USB hub - same intermittent issue.


      What usually happens is thje mifi initially connects to the host pc, then I manually select the
      connect to vm option. The driver starts installing in the vm, then it freezes.


      After googling around it seems I just need to kill off the vmware-vmx.exe process. The
      issue is I cannot seem to kill it! Nothing happens when using Task Manager -
      just remains there. Tried elevated command prompt, trying to kill using PID an
      name. Same with elevated powershell. I can end the Workstation tasks, but when
      I relaunch the app, the vm is still running in
      a frozen state.


      So, I'd be really grateful if someone could help me troubleshoot and
      resolve both or one of the following:


      1. VM's are sometimes crashing when I attach the Huawei mifi devices
      2. I cannot kill the vmware-vmx.exe without having to restart the host each time it happens



      Host PC:


      Windows 10 Pro

      Asus  ROG STRIX X299


      64GB Corsair Vengeance
      DDR4 3000MHZ


      Many thanks!

        1 2 3 Previous Next