12 Replies Latest reply on Sep 1, 2020 11:17 AM by UserOfVirtualMachines

    Mouse wheel scrolling skips clicks

    UserOfVirtualMachines Novice

      In my VMware guests, mouse wheel scrolling does not work correctly.

       

      How it should work: 1 "click" of the mouse scroll wheel should produce 1 line of scrolling.

       

      How it works: It takes fully 8 "clicks" of the mouse scroll wheel to produce 1 "click" worth of scrolling.

       

      The result is that scrolling is extremely slow. I can sit there turning and turning the scroll wheel and getting nowhere. It's really quite frustrating.

       

      This problem affects only the virtual machine guests. The mouse wheel works correctly in the Mac host (namely every "click" of the mouse wheel registers).

       

      What I have already tried:

       

      1. On the Windows 10 guest, I tried Settings -> Devices -> Mouse, every possible combination of settings. Setting it to scroll multiple lines at a time does NOT help. It makes scrolling jumpy and still takes fully 8 "clicks" of the scroll wheel to register 1 "click" worth of scrolling. NOT HELPFUL.

       

      2. Virtual Machine Settings -> Keyboard and Mouse. I do not see any helpful settings there. All the settings pertain to shortcut keys, not to mouse wheel.

       

      What else should I try?

       

      System information:

      macOS High Sierra version 10.13.6

      VMware Fusion version 11.1.0 (13668589)

      Windows XP guest

      Windows 10 guest

      Mouse: Logitech M705

        • 1. Re: Mouse wheel scrolling skips clicks
          RickShu Expert
          VMware Employees

          Hi UserOfVirtualMachines,

           

          Have you tried with the options in VMware Fusion=>Preferences=>General=>Gaming ?

           

          Regards,

          -Rick

          • 2. Re: Mouse wheel scrolling skips clicks
            UserOfVirtualMachines Novice

            Hi RickShu,

             

            Yes. Those options have absolutely no effect on mouse wheel movement. Optimizing for Gaming causes the mouse cursor to become stuck in the VM guest window.

             

            No matter what it takes 8 "clicks" of the mouse wheel to produce 1 "click" worth of scrolling. This was not the case in the past. It began with VMware Fusion 11.

            • 3. Re: Mouse wheel scrolling skips clicks
              UserOfVirtualMachines Novice

              Does anyone know what to do about this? Scrolling in any VM guest is painfully slow and jerky. It used to work. Now with VMware Fusion 11 it is broken.

              • 4. Re: Mouse wheel scrolling skips clicks
                UserOfVirtualMachines Novice

                So? No answer on this?

                 

                Has anyone else experienced the issue that mouse wheel scrolling SUCKS in guest VMs? It takes 8 "steps" of the scroll wheel to make 1 "step" worth of scrolling; 7 "steps" are totally ignored by the guest and only every 8th step counts.

                 

                This is affecting ALL my virtual machine guests regardless of their operating system. That means it is NOT a configuration issue of a guest OS.

                 

                Mouse wheel scrolling works as expected in the Mac host (every "step" of the scroll wheel results in scrolling; no steps are ignored), so this is NOT an issue with my Mac or my mouse.

                 

                The only thing remaining is VMware, where mouse wheel scrolling used to work perfectly and started acting this way ever since an update in the not-too-distant past.

                 

                Does VMware care? I haven't seen any substantive reply to this thread.

                • 5. Re: Mouse wheel scrolling skips clicks
                  keegoid Lurker

                  I have the same issue. Very slow scrolling. 8 or so clicks on the mouse wheel equals 1 scroll movement on the screen.

                   

                  Mac host version: 10.15.2

                  VMware Fusion version: 11.5.1

                  Mouse: Logitech MX Anywhere 2S connected via Bluetooth to Mac.

                  Guest VM: Ubuntu 19.10

                   

                  I really hope this can get resolved soon. It is really frustrating to scroll.

                   

                  Regards,

                  Keegan

                  • 6. Re: Mouse wheel scrolling skips clicks
                    masonfoley Lurker

                    I have the same issue.  Windows 10 host, Ubuntu 19.10 gust.  VMWare Workstation 15.5.  It's gotten to where I will use the scroll bar instead whenever I'm browsing in the guest.

                    • 7. Re: Mouse wheel scrolling skips clicks
                      snop Lurker

                      This problem exists so long, as I remember, some mouse drivers react better, but in general mouse wheel is buggy and skips or didn't catch all events ( of course vmware tools installed everytime ).

                      • 8. Re: Mouse wheel scrolling skips clicks
                        steve_atx Lurker

                        I have the same problem with workstation pro 15 on a centos 8 host inside of my Ubuntu 18 guest.  It is incredibly annoying, but I’m willing to tolerate it for now because workstation pro is the only solution that I found with 3D hardware acceleration (but only after I spent hours figuring out that a secret “allow blacklisted driver” flag was required for my graphics card). 

                         

                         

                        The only other thing that drives me nuts is that I can’t figure out how to make the guest fully capture the windows key (always goes to the host even in full guest input containment mode - forgot the name for this).

                        • 9. Re: Mouse wheel scrolling skips clicks
                          steve_atx Lurker

                          All mouse related usability quirks I noticed went away as soon as I changed the mouse settings to "always" use "game mode".  The mouse pointer became as sensitive as on the host and scrolling in the guest works perfectly.  I am on workstation pro 15 centos 8 host with ubuntu 18 guest.

                           

                          My other problem - exclusive mode doesn't capture some keys - also seems to be related to centos 8 using wayland by default.  Logging in using xorg instead fixed that problem.

                           

                          Now vmware workstation pro 15 works perfectly for me and is way better in every respect I can think of (guest performance, virtualization usability) than KVM or virtualbox.

                          • 10. Re: Mouse wheel scrolling skips clicks
                            bm Enthusiast
                            VMware Employees

                            These issues all sound like problems with what's called "Smooth Scrolling" or "Pixel Scrolling" (depending on your OS), where the host's mouse sends very fine-grained scroll events, and either the host isn't sending this consistently, or something is going wrong in the conversion so that the guest isn't getting the same level of sensitivity applied.

                             

                            You can probably work-around this by adjusting the following config options:

                            MacOS Hosts: mks.mouse.pixelScrollSensitivity (default value 8)

                             

                            It sounds like most of the MacOS users here with issues should set:

                            mks.mouse.pixelScrollSensitivity=1

                            (Although you can to adjust to different values as needed.)

                            Higher values mean that it requires more host scrolls to produce a single guest-scroll.

                             

                            Windows Hosts:

                            Depending on the precise problem, some combination of these options should help:

                            mks.win32.scalePartialScroll=TRUE

                            mks.win32.scaleScroll=TRUE

                            mks.win32.scrollScaleFactor=1200

                            Adjust the mks.win32.scrollScaleFactor as needed to increase/decrease the scaling.  Higher values means that a single host-scroll will turn into more guest-scrolls.

                             

                            I'd probably start with just the mks.win32.scalePartialScroll=TRUE option, and if that doesn't work, also add the mks.win32.scaleScroll=TRUE option, and then adjust the mks.win32.scrollScaleFactor from there if it seems to help, but only partially.

                             

                            Linux Hosts:

                            I haven't seen any reports of this on Linux before, and I'm not aware of a config option that can help.  To be honest, the Linux reports here sound more like mouse-movement problems rather than scroll-wheel problems, and might be due to Wayland/X11 interactions.  (The fact that it went away with the "Gaming Mouse" setting ,and works in X11 mode also confirms that.)  We'd have to investigate and get back to you, possibly with an option in a future version of Workstation.

                            1 person found this helpful
                            • 11. Re: Mouse wheel scrolling skips clicks
                              Groenendijk Lurker

                              Thanks,

                               

                              This has solved the issue for me.

                              • 12. Re: Mouse wheel scrolling skips clicks
                                UserOfVirtualMachines Novice

                                I am a MacOS user (VMware Fusion) and bm's suggestion of adding the following line to each virtual machine's .vmx file solved the mouse wheel scroll problem:

                                 

                                 

                                mks.mouse.pixelScrollSensitivity=1

                                 

                                 

                                Mouse wheel scrolling now works correctly in my Windows and Linux VM guests, which is to say that the clicks are no longer being divided by 8.

                                 

                                 

                                Note: Quite a few people here and in other venues have suggested to "always" use "game mode." That DOES NOT solve the problem at all. The only thing it does is prevent the mouse being able to exit the VM window, meaning I have to press a shortcut key to release the mouse and keyboard from the VM. Again, "game mode" DOES NOT solve the mouse scroll divide by 8 problem. Adding the above line to the .vmx file solved it for me.

                                 

                                 

                                Thank you to bm for this information.