1 2 3 Previous Next 44 Replies Latest reply on Sep 17, 2019 4:44 AM by EyeM

    macOS Catalina issue [beta]

    wtfmatt Novice

      Hello.  I installed the new macOS 10.15 beta today, and loaded fusion to find that my Windows 7 VM boots up and runs just fine, but only shows a black screen. I can see it in the library and even use it by typing, moving the mouse around in the black screen, and watching in the library but that's all. Has anyone experienced this before? I've tried reinstalling Fusion, to no avail. It also doesn't show anything during post/boot, so it's not a video driver issue I don't think.

       

      - Accelerate 3D Graphics is NOT checked.

      - I receive NO error messages.

       

      Screen Shot 2019-06-03 at 7.04.06 PM.png

        • 1. Re: macOS Catalina issue [beta]
          zhus Hot Shot
          VMware Employees

          From the thumbnail in VM Library, I see the Win7 VM has been booted up.

          Could you send Ctrl_Alt_Delete to the guest to see if the key event works?

          PS: After install Fusion, have you ever restarted host OS?

          • 2. Re: macOS Catalina issue [beta]
            lbalogh Novice

            As a workaround, you can enable VNC in the advanced section of your VM settings and connect with a VNC client. I just tried with VNC Viewer and it worked

            • 3. Re: macOS Catalina issue [beta]
              wtfmatt Novice

              Yeah as I was saying, everything works just fine when I send key/mouse strokes to the blank screen it appears in the library window. Just can't see it in the VM itself.

               

              I've restarted 30 times.

              • 4. Re: macOS Catalina issue [beta]
                zhus Hot Shot
                VMware Employees

                Hi wtfmatt,

                Could you please try these steps:

                1. Open System Preferences -> Security & Privacy.

                2. Select Screen Recording in the list.

                3. Click the lock and input password to make change.

                4. Make sure the checkbox for "VMware Fusion" item is checked. If not, check it.

                5. Restart Fusion.

                2 people found this helpful
                • 5. Re: macOS Catalina issue [beta]
                  crould Novice

                  Mine is nothing there

                  Screen Shot 2019-06-06 at 13.09.04.png

                  • 6. Re: macOS Catalina issue [beta]
                    zhus Hot Shot
                    VMware Employees

                    To add Fusion to the list, you can do this:

                    1. Open System Preferences -> Security & Privacy -> Privacy.

                    2. Select Accessibility in the list on left side, click "+", select "VMware Fusion.app" in Applications to add Fusion into the Allow the list and check the checkbox.

                    3. Launch Fusion, create a fake VM (I'm not sure if opening an existing VM has the same effect).

                    (File -> New, select "Create a custom virtual machine", select any operation system, press "Continue" several times then "Finish", Save the VM, it will be powered on automatically)

                    Then the following dialog will pop up, click Open System Preferences, it will be added to the list.

                    enableFusionForScreenRecording.png

                     

                    PS: If the message never pop up on your mac, try to enable Full Disk Access for Fusion. On one of my Mac, I didn't have this message popup, but it works with Full Disk Access enabled. 

                    1. Open System Preferences -> Security & Privacy -> Privacy.

                    2. Select Full Disk Access in the list on left side, click "+", select "VMware Fusion.app" in Applications to  add Fusion into the list.

                    • 7. Re: macOS Catalina issue [beta]
                      Hs0willowdale Lurker

                      I have the same issue with VMware 10 pro.

                      I created a new Debian VM. On starting the VM, I was not prompted for permission to allow screen To be recoded (Debian screen was just a black screen but I could see that in the VM explorer, the green deb install had been launched).

                      Moreover, I did not get the issue with Microsoft Teams (Which is slack Like product).

                      - teams correctly asked for permission on the first time launch

                      - teams is now registered in the system prefrrences to accept screen recording.

                      - VMware never asked for user permission

                       

                      Seems like It’s an api isssue. VMware product needs to be updated so that macOS can correctly ask for permission from the user.

                      • 8. Re: macOS Catalina issue [beta]
                        mcnaugha2 Novice

                        This solved the issue for me.

                         

                        Screen recording makes you think they’re up to something bad. So, I had denied. No sooner had I permitted the screen recording and re-launched Fusion, it was working normally.

                        • 9. Re: macOS Catalina issue [beta]
                          Hs0willowdale Lurker

                          Are you using fusion 10 or 11

                          • 10. Re: macOS Catalina issue [beta]
                            crould Novice

                            It won't popup for me

                            • 11. Re: macOS Catalina issue [beta]
                              Starlir Novice

                              For me Fusion is not in the list of Apps in Security/privacy/Screen Recording and these instructions do not generate the pop-up.  As such at the moment I can see no way of adding Fusion to the list of apps allowed in Screen recording and so continue to see a black screen.

                              • 12. Re: macOS Catalina issue [beta]
                                TheDov Novice

                                After I launched my VM the first time in Catalina and saw this issue (black screen, but active preview), I found this post, and did see VMWare Fusion in the list of apps for Screen Recording. I checked the box, and now it's working fine for me. Also, I never recall seeing a prompt to add the permission, either.

                                • 13. Re: macOS Catalina issue [beta]
                                  dima187 Novice

                                  my problem is my system preference crashes, no matter where i go user section or security section, it crashes..  any help to fix this issue, so i can get to the other part to fix my fusion problem?

                                  • 14. Re: macOS Catalina issue [beta]
                                    wowzamedia Lurker

                                    I am in this same predicament too. What version of Fusion are you running? From what I've gathered, VMWare 10.1.x does not seem to request this permission and cannot be manually added either. Please let me know if you are able to somehow get it working.

                                    1 2 3 Previous Next