2 Replies Latest reply on May 30, 2019 2:20 AM by sk84

    nsx upgrade to 6.2.2

    VivekMi Lurker

      Hi ,

       

      I am planning to upgrade vShield Manager to NSX 6.2.2 , what all precautions I need to take care of.

      Any help would be appreciated.

        • 1. Re: nsx upgrade to 6.2.2
          Sreec Master
          Community WarriorsvExpert

          If your setup is having only vSphere with vShield combination , you can follow below steps to upgrade the environment and be aware of the requirements

          1. Upgrade vShield Manager to NSX Manager
          2. Deploy NSX Controller cluster - optional, required for logical (distributed) routers and changing control plane mode to hybrid or unicast
          3. Update host clusters
          4. Update Transport Zone - optional, if NSX Controller cluster is deployed, can change control plane mode to hybrid or unicast
          5. Upgrade vShield App to NSX Distributed Firewall
          6. Upgrade vShield Edge to NSX Edge
          7. Upgrade vShield Endpoint to NSX Guest Introspection

           

          Based on the NSX use cases what you are planning to have and if you are sure some of the features like (Guest Introspection) is not required , you should uninstall those features and move forward with components/features that really require upgrade to retain the configurations. Ensure to take a backup of vCenter and vShield Manager prior to upgrade. An before proceeding with (Step 2-7) take a new backup of the upgraded NSX instance.

           

           

          Upgrade vShield Manager to NSX Manager

           

          Also do note that , there are few features that doesn't support direct upgrade(This is specific to NSX)

          NSX Services That Do Not Support Direct Upgrade

          • 2. Re: nsx upgrade to 6.2.2
            sk84 Expert
            vExpert

            NSX 6.2 is already End-of-Support since 2018/08/20 and EoL will be at 2019/08/20. I would therefore recommend upgrading to NSX 6.4.5 if your other VMware products supports this version. You can check the product compatibility here: VMware Product Interoperability Matrices

             

            But as far as I remember, it is recommended to upgrade to version 6.3.3 first, because there are significant changes in the VIB behavior and the operating system of the NSX controllers.