1 Reply Latest reply on May 22, 2019 3:12 PM by daphnissov

    Setting up SSO when users have an 'at' symbol in their username

    scottg03 Lurker

      We have a LDAP authentication source (using the OpenLDAP connection option) where are usernames are in the format username@domain.com and just supplying username causes authentication to fail. Of course, vCenter logins use the @ symbol or a backslash to identify which identity source to use. What I really need is to login with something like username@domain.com@myldapdomain.com or myldapdomain.com\username@domain.com, but that username format throws an error and fails to log in. Any help would be greatly appreciated.

        • 1. Re: Setting up SSO when users have an 'at' symbol in their username
          daphnissov Guru
          Community WarriorsvExpert

          In vCenter's SSO config, you can declare one external domain to be the default domain. When you do so, you can then login to vCenter using the username without having to specify the domain in which the user principal resides. If your OpenLDAP usernames use the UID attribute and there are special characters actually in the UID attribute, that would be one thing. Or if they're using sAMAccountName. Otherwise, try to configure your SSO default domain.