5 Replies Latest reply on May 23, 2019 1:38 AM by zyberion

    Microsoft Visio 2016 takes a long time to load the first drawing

    zyberion Lurker

      Hello everybody,

       

      After I log on to my VDI session, the first time I launch Visio is slow.

      It takes about 2-3 mintues to loads the default diagram.

       

      Consecutive launches of Microsoft Visio drawings within the same session are loaded fast.

       

      If I log off then log on again, the first time I launch Visio is slow and consecutive launches of Visio are fast.

       

      I assumed that UEM was not capturing the appropriate file from my profile so I started to dig a bit further.

       

      I have noticed that, on first launch, Visio

         - Spend a lot of time to query a specific Reg key. It takes more time if Appstack(s) are attached.

         - Create a file called content16.dat in <localappdata>\microsoft\Visio which looks like an index of Visio template.

       

      In order to fix the issue, I have tried to import/export that file by adding <localappdata>\microsoft\Visio in my UEM profile.

       

      The file is indeed exported when I log off then imported when I log in.

      Unfortunately I still encounter the issue.

       

      I have noticed that Visio erases the file and create a new file when I close Visio.

       

       

      Can you help me fix this issue?

       

      Regards,

        • 1. Re: Microsoft Visio 2016 takes a long time to load the first drawing
          zyberion Lurker

          In my previous post, I forgot to mention that

           

          We are running Horizon 7.4 and we provisioinned non-persistent virtual machines.

          The Operating System of the VM we provision is Windows 7 64bits

          We installed Office365 suite (version 1803) on the golden image (we had performance issue when deployed through AppVolume)

          • 2. Re: Microsoft Visio 2016 takes a long time to load the first drawing
            CharlesGraffSWC Lurker

            This is probably related to this KB: https://kb.vmware.com/s/article/2145683

             

            Try adding this to your snapvol.cfg in your writable where the article mentions.

            reverse_replicate_registry_key=\MACHINE\SOFTWARE\Microsoft\Office\ClickToRun

            or even

            exclude_registry=\REGISTRY\MACHINE\SOFTWARE\Microsoft\Office\ClickToRun\REGISTRY

             

            Adding the exclude_registry brought our launch time of Visio down from 5 minutes to about 30 seconds. We did not have any Appstacks (we had nothing but performance problems with AppStacks), only a writeable volume. O365 hammers this key with a huge number of calls (hundreds of thousands) and any appvolume or appstack attached caused the calls to take significantly longer, which adds up quickly. You can see this with a procmon analysis with an appvolume attached vs not.

             

            I had a ticket open with VMware with this and they did not have any great solution.

            reverse_replicate_registry_key=\MACHINE\SOFTWARE\Microsoft\Office\ClickToRun

            • 3. Re: Microsoft Visio 2016 takes a long time to load the first drawing
              zyberion Lurker

              Hello,

               

              Thank you for the feedback.

               

              In our environment we must deploy few applications through appstacks.

              Users may have up to 3 appstack and like you describe we have noticed performance issue related to appstacks.

               

              As we are running App-Volume v2.14, the following settings are already applied by default in snapvol.cfg

              reverse_replicate_registry_key=\MACHINE\Software\Classes

              reverse_replicate_registry_key=\MACHINE\SOFTWARE\Microsoft\Office\15.0\ClickToRun\REGISTRY\MACHINE\SOFTWARE\Classes

              reverse_replicate_registry_key=\MACHINE\SOFTWARE\Microsoft\Office\ClickToRun\REGISTRY\MACHINE\SOFTWARE\Classes

               

              As we have installed Office and any application that integrate with office suite on the golden image, we have also added this settings

              exclude_registry=\REGISTRY\MACHINE\SOFTWARE\Microsoft\Office            # Add 08022018 for Office

               

              Unfortunately we have no improvement.

               

              I have found the following article from IVANTI forums

              https://forums.ivanti.com/s/article/Microsoft-Visio-2016-takes-a-long-time-to-load-the-first-drawing

               

              The registry HKLM\SOFTWARE\Microsoft\Office\ClickToRun\REGISTRY\MACHINE\Software\Classes\Installer\Components\F6B8D9D6FE0D0CB4D84D90DDC62E3B** is already excluded since it is a child of

              HKLM\SOFTWARE\Microsoft\Office\ClickToRun\REGISTRY\MACHINE\SOFTWARE\Microsoft\Office

               

              And we already tried to set UEM accordingly with no success.

               

              The file just get overwritten after the very first launch of Visio when you log on to your VDI session.

               

              Regards

              • 4. Re: Microsoft Visio 2016 takes a long time to load the first drawing
                Rajeshkawle Lurker

                Thanks this settings worked for us with appstacks.

                 

                We have office 365 in golden image and Visio was taking 7 minutes to launch with appstacks attachment.

                We have updated the snapvol.cfg exclusion for HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\ClickToRun .

                Visio launch issue got resolved and launching in less than 30 sec.

                • 5. Re: Microsoft Visio 2016 takes a long time to load the first drawing
                  zyberion Lurker

                  Hello Rajeshkawle

                   

                   

                  In you snapvol.cgf,

                  do you have all these lines?

                    - reverse_replicate_registry_key=\MACHINE\Software\Classes

                    - reverse_replicate_registry_key=\MACHINE\SOFTWARE\Microsoft\Office\15.0\ClickToRun\REGISTRY\MACHINE\SOFTWARE\Classes

                    - reverse_replicate_registry_key=\MACHINE\SOFTWARE\Microsoft\Office\ClickToRun\REGISTRY\MACHINE\SOFTWARE\Classes

                  or do you only have the following line?

                    - exclude_registry=\REGISTRY\MACHINE\SOFTWARE\Microsoft\Office\ClicktoRun

                   

                   

                  Regards,