9 Replies Latest reply on May 23, 2019 7:54 AM by buckmaster

    Converge to Embedded

    joshuasatrapewei Lurker

      I'm trying to converge my external PSC into my vCSA, using the GUI tool. I'm running 6.7U2 on both the PSC and the vCSA, but the converge has been stuck at 8% for several days. Has anyone else run into this? My coworker ran into the same issue in his lab and I haven't been able to find anything online about it.

        • 1. Re: Converge to Embedded
          johncol Enthusiast
          VMware Employees

          can you check the converge log, located at /var/log/vmware/converge - ?

          One of the first steps is to validate the existing configuration then start to download the RPM's, be it from a repository or from the iso attached. This could be stuck here, but the log should show it. Attach the converge.log and the .json log if you can

          • 2. Re: Converge to Embedded
            joshuasatrapewei Lurker

            Here's a screenshot of both.

             

            2019-05-16_17-13-07.png2019-05-16_17-14-15.png

            • 3. Re: Converge to Embedded
              johncol Enthusiast
              VMware Employees

              not enough info there in the screeenshots - did you try to mount the iso? The workflow should pull down the 6 RPM's from there, for example :

               

              2019-04-04T08:19:49.147Z INFO converge Executing reconfiguring steps. This will take few minutes to complete.

              Please wait ...

              2019-04-04T08:19:49.147Z INFO converge Downloading RPMs

              2019-04-04T08:19:49.147Z INFO converge Collected client:rest as a part of Telemetry

              2019-04-04T08:19:49.349Z INFO converge VCSA ISO is mounted. Copying RPMs from the ISO.

              2019-04-04T08:19:49.358Z INFO converge ISO version : VMware-vCenter-Server-Appliance-6.7.0.30000-12885434

              2019-04-04T08:19:49.358Z INFO converge VC version : VMware-vCenter-Server-Appliance-6.7.0.30000-12885434

              • 4. Re: Converge to Embedded
                djones82 Lurker

                Did you ever solve this problem?  I'm seeing the exact same thing.  Looked at converge.log and it's stopped at the same place your's was.  I successfully did two of these last week following the exact same process and using the same vCenter build so not sure what's going on.

                • 5. Re: Converge to Embedded
                  lmagna Novice

                  Same problem for me ! I'll try with mounting iso.

                  • 6. Re: Converge to Embedded
                    DaneTruscott Novice

                    Same issues, is there a safe way to cancel this as there doesn't seem to be an option.

                    • 7. Re: Converge to Embedded
                      buckmaster Hot Shot

                      Attach the iso to vcsa, mount /dev/cdrom /mnt/cdrom

                       

                      as far as a backout plan, I always snapshot my psc's and vcsa's as a group since database replication  "SSO" is involved. To acheive a clean snapshot i shutdown all 4 VM's, then snapshot.  The I can revert to a safe clean state that I WAS in before the converge process.

                       

                      Tom

                      • 8. Re: Converge to Embedded
                        lmagna Novice

                        It works mounting iso with mount /dev/cdrom /mnt/cdrom on vcsa running vcenter.

                         

                        But I had to revert snapshot because I've restarted the vcenter to force stop the converge process and I had an error when I wanted to restart it "Cannot converge" or something like that and "converge already running" in logs of vcsa and I don't know how to clean flag indicates that converge is running.

                        • 9. Re: Converge to Embedded
                          buckmaster Hot Shot

                          Ensure you revert ALL VM's, PSC's and VCSA's.  And take snapshot of ALL VM's at the same time