3 Replies Latest reply on Jul 27, 2020 9:50 PM by stratician

    Expanding Disk Space in VMware for macOS (APFS Container Resize Error)

    lahmefc Novice

      Hello everyone.

       

      I want to expand the disk space, so I went into VMware settings and expanded disk capacity from 40GB to 80GB. It told me to then handle the partitions for it to take effect inside macOS.


      I launched and went to Disk Utility and see this

      I cannot resize the blue area for some reason, but I can highlight the "Free Space" area and delete it, which then makes the desired effect happen:

       

      Clicking "Apply" leads to the following error...

       


      Back to square 1. I went into Terminal and brought up diskutil list. Here are the results:

       

      So I want to expand disk0s2, used the following command: $ sudo diskutil apfs resizeContainer /dev/disk0s2 80 (80gb is what I have set in VMware settings)

       

      I also tried $ diskutil apfs resizeContainer disk0s2 0

       

      Both yield the same error:

       

       

      Any thoughts on what I may be doing wrong or how to successfully add space to the partition?

       

      Time machine is not enabled and there are no local backups to delete, I've run those commands in case (I've seen that as the solution across the web, no go for me)