4 Replies Latest reply on Sep 4, 2019 12:55 PM by paulc1

    Delete a binary?

    paulc1 Novice

      So I can unmap a binary, but it stays on the drive. I can delete the binary from the drive, but it remains in a "completed" state under My VMware.


      How do I really clear these completely so they can be re-downloaded in the future?

        • 1. Re: Delete a binary?
          paulc1 Novice

          Damn vCenter servers are the same unless I'm blind. I fat fingered the name of my vCenter, and editing the entry won't allow me to change the FQDN/Name. So now I'm stuck with this extra useless vcenter I can't delete. Of course I can delete the whole datacenter, but that seems kind of a nuclear option.


          Let me delete stuff!

          • 2. Re: Delete a binary?
            paulc1 Novice

            On the same topic and why I needed to delete binaries. Why does it ask to download all binaries after logging in to my vmware? How many customers want to download every binary? Seems kind of a weird choice.


            I had an issue where I couldn't download one binary with my cached credentials. I was getting a login failed error when clicking download, even though my "my vmware" login worked fine, so I had a coworker login with her credentials and she asked if she should click yes, and me not having seen the prompt because I've had my credentials in there since v1 said yes.


            And since there's no way to cancel the downloads we just had to wait for all of them to either fail or complete. I was deleting some of them from the hard drive immediately when they finished because my drive was filling up so fast.

            • 3. Re: Delete a binary?
              csiuscloud Lurker

              Did you ever find a solution for the issue you had? I am having the same problem.

              • 4. Re: Delete a binary?
                paulc1 Novice

                Nope. Now I need an old version of vRA, but I deleted the ova already because my hard drive was full, but its showing as completed under my vmware, so I can't redownload it. I tried using the API to re initiate the request, but it doesn't work. Also can't delete the request.


                Not sure what else to do unless there are some more hidden API calls not in swagger like delete request was.