0 Replies Latest reply on Apr 8, 2019 1:37 PM by kailash93

    Every keystroke from vcetner remote console is being repeated twice but only on workstation virtual machines and not server machines. Also, vCenter keeps telling me that the vmware tools is not installed when in fact it is; again only on Desktop VM's and

    kailash93 Lurker

      Every keystroke entered from vCenter 6.7 remote console is being repeated twice except for one random character or "."; and that too only on desktop/ workstation machines. I do not experience this issue on server machines which is pretty weird. I've come across a known workaround to the issue which is to add the following line to the vmx file: keyboard.typematicMinDelay = "2000000". But i do not believe it to be an ideal solution because it's not efficient to shutdown every desktop in the environment, edit the vmx file and bring it back up. Also, to add this workaround hasn't worked for everyone. Following is a link to the posting in regards to the same issue with the workaround and the client's responses:

      Annoying repeated keystrokes

       

      Also, VMware tools seems to be undetected every now and then, again only on Desktop machines. When logged into the computer, the tools are installed and running, it's just that the vCenter fails to detect it. I've tried rebooting the machine but doesn't work. The only solution right now that has worked for me is to either remount VMware tools from the vcenter, console into them and perform a repair or go to Control Panel --> Uninstall Program and Features --> VMware Tools --> Change --> Repair which is pretty annoying to do for multiple machines. Also, quite frustrating to see something like this during a crisis situation, when you want to bring your whole environment down systematically but you can'y because vCenter fails to detect the tools installed on the desktops.

       

      Also, both these problems combined together just adds up to the frustration.