5 Replies Latest reply on May 8, 2019 4:53 AM by POCEH

    VMware Converter KVM to VMware

    benjamin000 Enthusiast

      Hello

       

      I am doing some testing to convert some KVM machines ( Debian 9 ) and I receive the following error when the final stages are reached.

       

      FAILED: An error occurred during the conversion: 'GrubInstaller::InstallGrub: /usr/lib/vmware-converter/installGrub.sh failed with return code: 127, and message: FATAL: kernel too old Error running vmware-updateGrub.sh through chroot into /mnt/p2v-src-root Command:

      chroot "/mnt/p2v-src-root" /vmware-updateGrub.sh

       

      It is surprising that the error related to 'kernel too old' as it is a latest kernel on Debian 9.

       

      I am running the latest VMware Convert 6.2.0 on Windows.

      Destination machine - vSphere 6.7 U1

       

      I note from research that older versions of VMware Converter uses GRUB1 and GRUB2 is needed however this seems only applicable to older version of VMware Converter.

       

      The source machine is NOT using LVM and has one partition located in /

       

      Any advice would be appreciated.