4 Replies Latest reply on Jul 6, 2020 11:24 PM by scott28tt

    Can't join host to new vCenter

    Todd7913 Lurker

      I have 2 ESXi 6.0 hosts with vSphere Essentials licensing. They have never been in vCenter.

       

      I just installed vCenter 6.7 as an appliance on one of the hosts, ESXi02. I created a Data Center but when I attempt to add the host it gives me an error of, "A general system error occurred: passwd: Permission denied." However, during the process to add the host I enter the root user info and it can see all the VMs on the host. When it opens the option to select a license I get the following error, "Cannot decode the licensed features on the host. Changing its current license might fail or some features might become unavailable."

       

      On the host I see errors that a new vpxuser already exists. That is followed by the same permission denied error above.

       

      To make matters worse, (and maybe a separate issue) I can't change the root password. I've tried from the vSphere Client and SSH and the DCUI. All say permission denied or it doesn't meet the complexity requirements. I've also tried changing the Advanced Security setting, "security.PasswordQualityControl" to allow me to change the password but it didn't help.

       

      Any help would be greatly appreciated.