4 Replies Latest reply on Apr 3, 2019 6:00 PM by woocatcat

    vSAN iSCSI Target Service Not supported

    woocatcat Lurker

      I have three vSAN clusters. The version of VCSA was 6.7.0.21000 , and ESXi hosts's version was  6.7.0, 10302608 . In one of vSAN Cluster , I've enabled vSAN iSCSI Target Service and configured iSCSI LUN. My App Server have connected to the iSCSI LUN.

       

      Recently,I've found the configuration of vSAN iSCSI Target has disappeared in cluster configure - vSAN. And vSAN iSCSI Target Service's status become to unsupported. I got a yellow alert under the vSAN iSCSI Target Service : " At least one host version is lower than 6.5, upgrade the host version."

      76453425-C002-4FC3-9A2F-5FA568CCDD4A.png

       

      I've checked all three clusters VSAN iSCSI Target Service, there ware same error. I'm sure all of my ESXi hosts was version 6.7.

      Can any one give me a hand ?

      Thank you very much.

        • 1. Re: vSAN iSCSI Target Service Not supported
          TheBobkin Virtuoso
          vExpertVMware Employees

          Hello woocatcat,

           

           

          Welcome to (posting on) Communities.

           

          *Generally* if you see some aspect of a host as being detected as a lower version than it is, it is due to lack of proper communication between one of the various daemons on the ESXi side or the services they communicate with in vCenter - as you have this on all clusters it is likely to be on the vCenter side.

           

          Check if vSAN Health (Cluster > Monitor > vSAN > Health) is functional and shows the relevant checks for vSAN iSCSI (e.g. vitd liveness etc.) - if the Health check is blank, not refreshing or not showing full correct information then restart Health and Client services on the vCenter:

          # service-control --stop vmware-vsan-health

          # service-control --start vmware-vsan-health

          # service-control --stop vsphere-client

          # service-control --start vsphere-client

           

           

          Bob

          • 2. Re: vSAN iSCSI Target Service Not supported
            woocatcat Lurker

            Hi Bob!

                 Thank you very much for your reply.

                 I've check my VSAN cluster 's health . All of objects was green status include vSAN iSCSI target service .

            1074FDE8-EBF3-49CB-85AE-398AAD7CE655.png

                 I've tried reboot VCSA.

            • 3. Re: vSAN iSCSI Target Service Not supported
              TheBobkin Virtuoso
              VMware EmployeesvExpert

              Hello woocatcat,

               

               

              Are you 100% positive that all hosts are on 6.7 U1 (build: 10302608) or later and vCenter is indeed on 6.7 U1b as you stated?

              Please validate this as 6.7 GA + vSAN 6.7 U1 are not compatible.

               

              If it is only one/few nodes which are failing to retrieve host capabilities and thus triggering this response you may be able to identify this from the vsan health service logs (/var/log/vmware/vsan-health/vmware-vsan-health-service.log), e.g. messages such as this where it shows no capabilities listed::

              2019-04-03T11:11:11.11Z INFO vsan-mgmt[Thread-12345] [VsanVcCapabilitySystemImpl::RetrieveHostCapabilities opID=noOpId] Host: host-11, version: 5, capabilities:

               

               

              Bob

              • 4. Re: vSAN iSCSI Target Service Not supported
                woocatcat Lurker

                The problem have been resolved . I followed your operation tips , restarted the VSAN-health service and vSphere-client ,then iSCSI Taget Services have been recover.

                I've seen the log as you said, every host was version: 5 .

                 

                Thank you very much.