7 Replies Latest reply on Apr 28, 2020 2:24 AM by SvenVanRoeyen

    VCSA 6.7: Postgres Archiver Service stopped & PSC Health/vCenter Server "degraded"

    Meathook Novice

      Hi Everyone,

       

      I'm currently setting up a new environment using ESXi 6.7 with an vCenter appliance deployed on the host. Setting up the hsot and the vCenter worked pretty well, and so far everything seems to be working alright, but I noticed some strange behaviour regarding the services of the vCenter:

       

      VMware Postgres Archiver:

       

      This service seems to change to status "stopped" every once in a while. I searched the KB and found a tip to change the wal_sender_timeout parameter to 600s, so the service doesn't run into any timeouts, but sadly this didn't help. I tried setting wal_sender_timeout to 0 (disabling the timeout), bu the issue still persists.

       

      VMware Knowledge Base

       

      My logfiles present the same Messages as described in this KB-article:

       

      /var/log/vmware/vpostgres/pg_archiver.log-[n].stderr:

       

      ERROR  pg_archiver could not receive data from WAL stream: server closed the connection unexpectedly
              This probably means the server terminated abnormally

              before or while processing the request.

       

       

       

      /var/log/vmware/vpostgres/postgresql-[nn].log:

       

      [unknown] archiver LOG:  terminating walsender process due to replication timeout

       

      wal.png

       

       

      VMware PSC Health & VMware vCenter Server:

       

      Both of these services currently show up as "degraded":

       

      services.jpg

       

      Meanwhile the summary page reports everything as "good":

       

      good.jpg

       

      The appliance has been assigned 16GB of RAM and 2vCPUs. Current Version:

       

      version.jpg

       

      Any ideas how to fix these services, or where to check for further information about the status of the PCS Service and the vCenter Server?

       

      With regards,

      Fabian