6 Replies Latest reply on Aug 17, 2019 9:22 AM by hsben

    Bridged Networking Not Working on Windows 10 Host

    mmartin0926 Enthusiast

      Hello All,

       

      This is the second discussion I'm posting regarding this issue as its still a problem after just updating VMWare Workstation Player to Version 14.1.5 build-10950780. And I never got any replies to my original post...

       

      It appears that VMnet0 still is not working after the upgrade. When using the default network settings with the Virtual Network Editor, and selecting "Bridged: Connected directly to the physical network" in the VM's settings, the virtual machine disconnects from the network and then reconnects. However, it stays connected using VMnet8 (*NAT). I can tell because its using the IP DHCP Pool addresses shown in Windows' ipconfig for vmnet8.

       

      Also, running ipconfig /all in windows doesn't show that a VMnet0 actually exists. I assume you would normally see a VMnet0 adapter in ipconfig's output.

       

      I can sort of workaround Bridged by using the Virtual Network Editor and setting VMnet8 as the Bridged adapter. However, when I do this I can only Manually select which Physical Adapter I want to use, i.e. Ethernet Adapter or Wi-Fi Adapter. And also, when doing this only the Ethernet Adapter option works, won't work when manually choosing the Wi-Fi adapter in the editor, the VM just never connects to the Wi-Fi.

       

      Host: Windows 10 Pro (*10.0.16299 Build 16299)

      Guest: Linux - OpenSuSE 11.4

       

      Thanks in Advance,

      Matt

        • 1. Re: Bridged Networking Not Working on Windows 10 Host
          RDPetruska Guru
          User ModeratorsvExpert

          Also, running ipconfig /all in windows doesn't show that a VMnet0 actually exists. I assume you would normally see a VMnet0 adapter in ipconfig's output

          No, VMnet0 is not an adapter, but a client.  In your physical NIC configuration settings, you should see the "VMware Bridge Protocol" or similar setting.

           

          Are you sure the VM is still connected when you change from NAT to Bridged?  Many newer Linux OSs cache the network adapter settings, and if you are changing the subnet, etc. it is connected to on the host, you have to do some reconfiguration in the guest. 

          • 2. Re: Bridged Networking Not Working on Windows 10 Host
            mmartin0926 Enthusiast

            Thanks for the reply and sorry for the delay. Never received any notification that I had a reply, sorry about that.

             

            Correct, in my Windows 10 host, if I check the Properties page of my Physical Network Adapters I can see that protocol your talking about, which is enabled.

             

            So currently, the VM's Network Adapter in VMware Player shows "Bridged", as you can see below.

             

            Then, looking on the VM itself running ifconfig, it shows the following, which is not our Wired network's subnet:

            # ifconfig

            eth0      Link encap:Ethernet  HWaddr 00:0C:29:2B:09:45 

                    inet addr:192.168.153.129 Bcast:192.168.153.255  Mask:255.255.255.0

                      inet6 addr: fe80::20c:29ff:fe2b:945/64 Scope:Link

                      UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1

                      RX packets:243 errors:0 dropped:0 overruns:0 frame:0

                      TX packets:232 errors:0 dropped:0 overruns:0 carrier:0

                      collisions:0 txqueuelen:1000

                      RX bytes:22586 (22.0 Kb)  TX bytes:22368 (21.8 Kb)

                      Interrupt:18 Base address:0x2024

             

             

            On my Windows host, ipconfig shows:

            Ethernet adapter VMware Network Adapter VMnet8:

             

               Connection-specific DNS Suffix  . :

               Description . . . . . . . . . . . : VMware Virtual Ethernet Adapter for VMnet8

               Physical Address. . . . . . . . . : 00-50-56-C0-00-08

               DHCP Enabled. . . . . . . . . . . : No

               Autoconfiguration Enabled . . . . : Yes

               Link-local IPv6 Address . . . . . : fe80::547d:7daf:4bdf:1b1e%24(Preferred)

              IPv4 Address. . . . . . . . . . . : 192.168.153.1(Preferred)

               Subnet Mask . . . . . . . . . . . : 255.255.255.0

               Default Gateway . . . . . . . . . :

               DHCPv6 IAID . . . . . . . . . . . : 402673750

               DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-21-CA-90-87-54-E1-AD-4C-97-1E

               DNS Servers . . . . . . . . . . . : fec0:0:0:ffff::1%1

                                                   fec0:0:0:ffff::2%1

                                                   fec0:0:0:ffff::3%1

               Primary WINS Server . . . . . . . : 192.168.153.2

               NetBIOS over Tcpip. . . . . . . . : Enabled

             

            And then the Virtual Network Editor is showing the following:

             

            So I'm not really sure what the problem is. But, it won't work with vmnet0... I even just upgraded VMware Player to 14.1.6 build-12368378 and the issue is still happening after the update finished.

             

            However, if in the Virtual Network Editor I change VMnet8 to a Bridged connection, and then manually select the Ethernet adapter, it appears to work and my VM gets an IP Address on the Wired subnet. But, if I change it to bridge the Wi-Fi adapter, it doesn't work.

             

            Is there any kind of log somewhere host or guest, that would say if and why VMnet0 is failing?

             

             

            Thanks Again,

            Matt

            • 3. Re: Bridged Networking Not Working on Windows 10 Host
              mmartin0926 Enthusiast

              I also just read a few posts saying that wireless isn't available to the Guest VM unless you do a USB Wi-Fi adapter and connect it to the VM...?

               

              Is that true, or is that more for connecting the Guest to a different SSID then then Host is connected to?

               

              Post --> no wireless recognition in guest Linux

               

              -Matt

              • 4. Re: Bridged Networking Not Working on Windows 10 Host
                ColonelTom Lurker

                Folks - I just encountered this exact same thing. Running Windows 10 host with Windows Server 2016 guest. I have bridged networking enabled for the guest which should be bound to VMnet0 and getting an IP address from my home router. However, the guest is not getting an IP address from my router but from an address range configured in VMnet8 and it's DHCP settings. I also tried to force a static IP that I know should work with the network but that doesn't work and the guest has NO network connectivity. I am running VMWare Workstation 15 and just upgraded with the latest updates. Any advice is welcome.

                 

                Thanks,

                Stuart Cobb

                • 5. Re: Bridged Networking Not Working on Windows 10 Host
                  mmartin0926 Enthusiast

                  Thanks for the verification Stuart. Those are my exact same symptoms.

                   

                  If you run the Virtual Network Editor, are you also able to change VMnet8 to Bridged protocol and manually set it to use the Ethernet adapter? If I do that I can get bridged working. However, it doesn't work with the Wi-Fi adapter, only Ethernet.

                   

                  So it appears the issue is with VMnet0 itself, as far as I can tell...

                   

                  -Matt

                  • 6. Re: Bridged Networking Not Working on Windows 10 Host
                    hsben Novice

                    I have the same problem.  There is def a bug here.  So what I did was remove the default VMNet1 and VMNet8 adapter from the Virtual Network Editor.  Then I set VMNet0 to Host only (this is just temporary, I needed to free up my external network adapter as I only have one).  Then I recreated VMNet8 manually and set it to bridged mode and selected the external network adapter I am using.  Removed the VMNet0, and VIOLA!. 

                    1 person found this helpful