4 Replies Latest reply on Mar 7, 2019 4:55 AM by OffensiveEggs

    Video Memory shows up as 2MB

    OffensiveEggs Lurker

      So I'm trying to play an old game on a Windows XP VM, but my VRAM shows up as 2MB, whilst it is set at 1GB. Can someone help?

       

      Some specs:

      OS (host) = Windows 10 Home 64-bit

      CPU = Intel Core I3 2120 (3.30GHz)

      RAM = 8GB

      GPU = AMD Radeon R7 250

      Samsung SSD

       

      Screenshot attached.

       

      I am using my optical drive to install from the disc. When I install the game, I can't play it because it crashes immediately.

      The game I want to play is Donald Duck: Quack Attack

      Thanks!

        • 1. Re: Video Memory shows up as 2MB
          RDPetruska Guru
          vExpertUser Moderators

          How is your virtual machine set up?

          Have you installed VMware Tools in the VM yet?

          • 2. Re: Video Memory shows up as 2MB
            OffensiveEggs Lurker

            I don't have a lot of knowledge about VMs, so i don't know if it is set up properly. Also don't know if I have the tools installed. I'll list everything. Thanks for helping!

             

            Probably don't have those tools.

             

             

            Memory:

                Memory: 512 MB

            Processors:

                Number of cores: 1

                Not virtualizing anything

            Hard Disk:

                Disk File: C:\Users\admin\Documents\Virtual Machines\Windows XP Professional\Windows XP Professional.vmdk

                Used Capacity: 2.2GB

                Maximum Size: 40GB

                Have not used any disk utilities

            CD/DVD:

                Connect at power on

                Using physical drive - D:

            Floppy:

                Connect at power on

                Using File: autoinst.flp

            Network Adapter:

                Connect at power on

                Using connection NAT

            USB Controller:

                USB 2.0, sharing BlueTooth devices

            Sound Card:

                Connect at power on

                Using default host sound card

            Printer:

                "Virtual printers must be enabled in the preferences"

            Display:

                Accelerate 3D graphics is checked, "You must update Tools to enable 3D acceleration in this virtual machine"

                Using host settings for monitors

                Graphics memory: 1GB

             

             

            Options

             

            General:

                Guest OS: MS Windows

                Working directory: C:\Users\admin\Documents\Virtual Machines\Windows XP Professional

                Enhanced Keyboard off

            Power:

                nothing selected

            Shared Folders disabled

            VMWare Tools:

                Not synchronizing guest time with host

                Using application default

            Unity:

                Showing borders and badges

                Applications menu enabled

            Autologin not available

             

            Tysm for helping

            • 3. Re: Video Memory shows up as 2MB
              RDPetruska Guru
              vExpertUser Moderators

              The settings look fine, but yes, you need to install the VMware Tools inside the guest - they include drivers for the virtual hardware, including the video card.  There should be a menu option to Install VMware Tools.  This will mount an iso image to the VM's optical drive with the installers, and run setup.exe inside the guest.  Note that the ISO will need to be downloaded first (and *should* happen automatically by Player).

              • 4. Re: Video Memory shows up as 2MB
                OffensiveEggs Lurker

                Still not solved, but thnx for trying to help. The message didn't show up this time, but it still crashes when I boot up the game.

                 

                 

                EDIT: I used compatibility options to fix it. I can now properly play the game!!!