6 Replies Latest reply on Mar 6, 2019 6:02 PM by nitta0814

    標準仮想スイッチのアップリンクのNICチーミングについて

    nitta0814 Novice

      【構成】

           <接続>

                CiscoのスタックSWにESXi#1~3(3台)とPC(1台)を接続しております。

                管理通信用の仮想スイッチにアップリンクを各ESXi2つずつ登録しております。

       

           <仮想スイッチの設定>

                vmnic0     アクティブ

                vmnic1     アクティブ

                リンクダウン

                スイッチへの通知:はい

                ポリシー:IPハッシュに基づいたルート

                リバースポリシー:はい

                フェイルバック:はい

       

              <Ciscoスイッチのポート>

          すべて同一セグメント

                     Channelグループ11     ON     ON

                     Channelグループ12     ON     ON

                     Channelグループ13     ON     ON

       

      【試験開始時点の状態】

       ・各ESXiの仮想スイッチには、1つのアップリンクのみ接続する

       

      【質問事項】

       ・試験開始時点では「PCから各ESXiへの通信」と「各ESXi同士の通信」が可能です。

        ESXi#1のアップリンクを両方接続した状態では、「PCから各ESXiへの通信」は可能ですが、「各ESXi同士の通信」が出来なくなります。また、ルーティングされている他のセグメントからも対象のESXiに対して通信出来なくなります。

         

       最終的には2本アクティブで冗長化し、一方が抜けている時や両方接続されていても

       通信が行えるようにしたいです。アドバイスを頂けないでしょうか。

       

      宜しくお願いいたします。

        • 1. Re: 標準仮想スイッチのアップリンクのNICチーミングについて
          gowatana Master
          User ModeratorsvExpert

          こんにちは。

           

          投稿された内容ですと、

          ESXi側は物理的な情報となっていて、一方、物理スイッチ側は論理的な情報と見受けられます。

          少なくとも、ESXiのvmkポートをどう構成しているか、

          物理スイッチ(できれば物理ポートも)との物理的な結線はどうしているか、

          といった情報がないと、状況の想像が難しそうかなと思いました。

           

          あと、仮想スイッチの設定も、実際には存在しなそうな項目があります。

          念のため、実機の設定を見直したほうがよいかもしれません。

          1 person found this helpful
          • 2. Re: 標準仮想スイッチのアップリンクのNICチーミングについて
            kawaman Hot Shot
            vExpertVMware Employees

            標準仮想スイッチ(vSS)の場合、チャネルは限られる構成になるので、以下過去のスレッドの参照先などでスイッチ側とESXi側で設定を再確認してみてください。

            今回はonなので該当しないかも知れませんが、LACPの場合はvDSが必要になります。

            ESXiでチーミング設定したポートに2本LANケーブルを接続すると通信できない

            1 person found this helpful
            • 3. Re: 標準仮想スイッチのアップリンクのNICチーミングについて
              nitta0814 Novice

              ご回答頂きありがとうございます。

               

              ご案内頂いたスレッドの投稿者の状況と恐らく同じ現象だと思います。

              そちらでも原因が判明していないため、スイッチの設定とESXiの設定を全パターン試して、

              可能なものを探したいと思います。

              • 4. Re: 標準仮想スイッチのアップリンクのNICチーミングについて
                nitta0814 Novice

                ご回答頂きありがとうございます。

                 

                情報をいかに補足いたします。

                 

                【ESXi#1】

                 仮想スイッチ0

                  vmk0:192.168.235.210

                  アップリンク:vmnic0,1

                 

                【ESXi#2】

                 仮想スイッチ0

                  vmk0:192.168.235.213

                  アップリンク:vmnic0,1

                 

                【ESXi#3】

                 仮想スイッチ0

                  vmk0:192.168.235.216

                  アップリンク:vmnic0,1

                 

                【PC】

                     IP:192.168.235.13

                 

                【Ciscoスイッチ】

                 P1/0/1     ESXi#1 vmnic0

                          access mode 235

                          チャネルグループ11 ON

                    P2/0/1     ESXi#1 vmnic1

                          access mode 235

                          チャネルグループ11 ON

                 

                 P1/0/2     ESXi#2 vmnic0

                          access mode 235

                          チャネルグループ12 ON

                    P2/0/2     ESXi#2 vmnic1

                          access mode 235

                          チャネルグループ12 ON

                 

                 P1/0/3     ESXi#3 vmnic0

                          access mode 235

                          チャネルグループ13 ON

                    P2/0/3     ESXi#3 vmnic1

                          access mode 235

                          チャネルグループ13 ON

                 

                仮想スイッチの設定(ESXi#3)

                • 5. Re: 標準仮想スイッチのアップリンクのNICチーミングについて
                  Mochi_Damo Novice

                  内容から可能性があるかなと思う箇所です。

                   

                  1. スイッチの設定について

                  以下のような設定になるかと思いますが、問題なさそうですか?

                   

                  ---------------------------------------------------------------------------------------------

                  # 論理ポート側

                  interface Port-channel11

                  switchport access vlan 235

                  switchport mode access

                   

                  # 物理ポート側

                  interface GigabitEthernet1/0/3

                  switchport access vlan 235

                  switchport mode access

                  channel-group 11 mode on

                   

                  interface GigabitEthernet2/0/3

                  switchport access vlan 235

                  switchport mode access

                  channel-group 11 mode on

                   

                  ※ 「access mode 235」はVLANのことかと思っています。

                   

                  画像から、仮想スイッチの設定は「External Switch Tagging」かと思いますので、

                  CISCOスイッチ側で誤ってtrunkにしていないか確認したほうが良いかと思います。

                  ---------------------------------------------------------------------------------------------

                   

                  2.仮想マシンポートグループの設定について

                   

                  仮想スイッチ側のチーミングポリシーは、IPハッシュにしているが、

                  仮想マシンポートグループ側で、チーミングポリシーを、IPハッシュから別のポリシーに

                  オーバーライドしていたりしないでしょうか?

                   

                   

                  よろしくおねがいします。

                  2 people found this helpful
                  • 6. Re: 標準仮想スイッチのアップリンクのNICチーミングについて
                    nitta0814 Novice

                    ご確認頂きありがとうございます。

                     

                    ご指摘頂いたとおり、オーバライドしておりました。

                    今後は気をつけます。

                     

                    ありがとうございました。