11 Replies Latest reply on May 11, 2019 6:54 PM by Atul_

    View planner 4.0 pre-defined workloads

    chamay Novice

      Has anyone tried VP 4.0? I am at lost trying to set workload to run. Is there any pre-defined workloads came with VP 4.0? Any hint? Thanks.

        • 1. Re: View planner 4.0 pre-defined workloads
          Atul_ Enthusiast
          VMware Employees

          View Planner ships with default workloads like office, browsers, pdf reader etc. you can get a complete list in "WORKLOAD" tab of the UI. Collection of workloads are called workprofile. For starters you should use a predefined workprofile like "standardTestProfile_chrome" that contains office, pdf, video and chrome workloads. you can check out "WORKPROFILE" tab in UI for details.

           

          Finally for configuring a test template you should navigate to "RUN PROFILE" tab click "new" and fill required values including work profile see Creating a Run Profile  for details. Then this run profile can be used to start new test in "RUN" tab see Starting a View Planner Run.

           

          If you are a new user and have not started setup yet, I would recommend starting from Perform a Local Mode Test topic and follow the steps for setup and first local mode test.

          • 2. Re: View planner 4.0 pre-defined workloads
            chamay Novice

            Thanks Atul_ for your respose. I had expected exactly what you described to find a complete list in the "WORKLOAD" tab and predefined workprofiles in the "WORKPROFILE" tab but I found none. Both tabs shows empty lists. I want to verify if someone find the list of workloads and predefined workprofiles in VP 4.0 then I must have done something wrong.

            When I click the ADD button in the WORKLOAD UI, the popup shows a WORKLOAD NAME input box and a VERSION input box. If I know the name of workload I can manually enter it. If you know the names of the workloads please give them to me. Thanks again.

            • 3. Re: View planner 4.0 pre-defined workloads
              Atul_ Enthusiast
              VMware Employees

              This might have happened due to an issue during initialization, can you ssh into harness and send  file "/opt/vmware/var/log/firstboot" to viewplanner-info@vmware.com?  Default SSH credentials can be found here Accessing Command Tool .

               

              Now to fix your issue:

              - Start view planner command line tool using steps in  Accessing Command Tool 

              - Copy paste following commands in command line tool, and recheck the workload and workprofile tab in UI once done:

               

              workload -a vp_7Zip -v 1.0

              workload -a vp_Adobe -v 1.0

              workload -a vp_Chrome -v 1.0

              workload -a vp_IEWebAlbum -v 1.0

              workload -a vp_msExcel -v 1.0

              workload -a vp_msOutlook -v 1.0

              workload -a vp_msPowerPoint -v 1.0

              workload -a vp_msWord -v 1.0

              workload -a vp_optimizeWin10 -v 1.0

              workload -a vp_viewConnection -v 1.0

              workload -a vp_winMediaPlayer -v 1.0

              workload -a vp_ChromeWebAlbum -v 1.0

              workload -a vp_EdgeBrowse -v 1.0

              workload -a vp_EdgeWebAlbum -v 1.0

              workload -a vp_RandomFileGenerator -v 1.0

              workload -a vp_MoveFiles -v 1.0

              workload -a vp_CompressFolder -v 1.0

              workload -a vp_CopyFiles -v 1.0

              workload -a vp_clientDrivenExample -v 1.0

              workload -a vp_pythonExample -v 1.0

               

              workProfile --add standardTestProfile_chrome --description "Standard test work profile with chrome browser, can be used for standard benchmark test." --addWorkloads vp_Adobe,vp_Chrome,vp_msExcel,vp_msOutlook,vp_msPowerPoint,vp_msWord,vp_ChromeWebAlbum,vp_winMediaPlayer

               

              workProfile --add standardTestProfile_edge --description "Standard test work profile with edge browser, can be used for standard benchmark test." --addWorkloads vp_Adobe,vp_msExcel,vp_msOutlook,vp_msPowerPoint,vp_msWord,vp_winMediaPlayer,vp_EdgeBrowse,vp_EdgeWebAlbum

               

              workProfile --add fileOperationsTestProfile --description "Work profile for file operations, Includes file generate, copy, move and compress workloads, File size can be modified from workload configuration files." --addWorkloads vp_RandomFileGenerator,vp_MoveFiles,vp_CompressFolder,vp_CopyFiles

              • 4. Re: View planner 4.0 pre-defined workloads
                chamay Novice

                Wow! That is precisely what I am looking for. Thank you so much Atul_.

                • 5. Re: View planner 4.0 pre-defined workloads
                  chamay Novice

                  I post another question here since it is related to the issue here. The log /opt/vmware/var/log/firstboot shows that the /root/viewplanner/setup is missing in the ova. I just wonder what else the firstboot script does.

                  The content of firstboot log file as follows

                  Appliance Name - viewplanner

                  Configuration for eth0 found

                  Device : eth0

                  Ip : 192.168.1.25

                  Netmask : 255.255.255.0

                  Gateway : 192.168.1.10

                  DNS : 192.168.1.10

                  chmod: cannot access '/root/viewplanner/setup/harness_first_boot.sh': No such file or directory

                  This script is executed on first boot only.

                  PER MESSAGE COMPRESS PerMessageDeflate(is_server = False, server_no_context_takeover = False, client_no_context_takeover = False, server_max_window_bits = 15, client_max_window_bits = 11, mem_level = 8)

                  Error in reading file /root/viewplanner/setup/harness_init_db.vpscript

                  Supported command:

                    vpcmd -u <username> -p <password> [optional] -c <command> -f <file>

                    [Options]

                    -u, --username

                    Username

                    -p, --password

                    User password

                    [optional]

                    -c, --command

                    command to be ran

                    -f, file

                    Path of VP script file

                   

                  ########## Remove setup folder ##########

                  ########## Remove setup folder ##########

                   

                  I run local mode test with 1 desktop VM and got error cannot find the desktop vm; found 0 expected 1 or something like that.

                  • 6. Re: View planner 4.0 pre-defined workloads
                    Atul_ Enthusiast
                    VMware Employees

                    This one should not be related to previous issue. For this you should check following:

                     

                    1- Check if view planner agent is installed in the desktop VM, and there is no error in viewplanner desktop agent command prompt after boot.

                    2- Check if desktop VM is configured to do auto logon.

                    3- Have you added your vCenter in Server -> Infra server tab and tested the configuration using test button.

                    4- Check if your desktop VM exist in same data center as provided with infra server details in Server -> Infra server tab.

                    5- Have you configured local mode test with Horizon View or just with infra server (both should work)

                    6- Are you using instant clones?

                    • 7. Re: View planner 4.0 pre-defined workloads
                      chamay Novice

                      I was  using linked clone pool and did all 5 things you mentioned. I looked at a log in /root/viewplanner/harness_core/vpresults/; it claimed that the desktop vm was in customizing state. Indeed it was stuck in customizing state when I went back to Horizon connection server.

                      When I tried to build a linked clone pool with quickprep without any scripts then it was fine and the desktop vm is in available state but it was stuck at customizing if I selected sysprep (autologin and join domain).

                      If I connect to the desktop clone at vcenter web ui, there is a dialog with message "Windows could not continue with the installation. Restart the computer ...". I clicked the OK button and it restarted. When it came back the auto login working and password was set to Q1w2e3r4! It also joined the domain but it is still in customizing state in Horizon View Server. Run again, same error.

                      Once again thanks for your response.

                      • 8. Re: View planner 4.0 pre-defined workloads
                        Atul_ Enthusiast
                        VMware Employees

                        This issue needs to be fixed first, View Planner can work when VDI setup is ready and working properly. Do you need to use Horizon View for this test? If you can send your use case and test plan to viewplanner-info@vmware.com, I might be able to help you with required setup.

                        • 9. Re: View planner 4.0 pre-defined workloads
                          chamay Novice

                          I understand that and working to fix the issue. I will contact you later. Thanks for your offer.

                          • 10. Re: View planner 4.0 pre-defined workloads
                            RAILITY Novice

                            Thanks Atul_ for your respose. I had expected exactly what you described to find a complete list in the "WORKLOAD" tab and predefined workprofiles in the "WORKPROFILE" tab but I found none. Both tabs shows empty lists. I want to verify if someone find Audacity Find My iPhoneOrigin the list of workloads and predefined workprofiles in VP 4.0 then I must have done something wrong.

                            • 11. Re: View planner 4.0 pre-defined workloads
                              Atul_ Enthusiast
                              VMware Employees

                              This is a know issue in few deployments. Follow correct answer in this thread to fix it.