1 Reply Latest reply on May 20, 2020 12:01 PM by La_Poutine_

    Change resolution of framebuffer/TTY

    nitrobay Lurker

      Hello,

      I use arch linux. I use vmware workstation player 15. I installed the vmware tools. In a desktop environement resizing works however in the default terminal before opening desktop (tty for example) the window is too small,

      Whether in vmware's display options I set a fixed resolution (like 3000X2000) or I choose to have same resolutions in my guest than my host (windows 10, I have a 3000x2000) doesn't change anything the resolution reported by hwinfo --framebuffer are between 400x300 and 1152x864 none of them being big enough. I follow the guide https://wiki.archlinux.org/index.php/GRUB/Tips_and_tricks set the framebuffer resolution and so i change the GRUB's config file GRUB_GFXMODE to the max resolution I of the hwinfo --framebuffer list I do the reload of the config with grub-mkconfig and reboot but still the framebuffer's size is never changin.

      So my tty terminal is like 1/30 of my screen (incredibly annoying on a 3000x2000 13 inches screen) even tho once again resizing a desktop env when I launch XORG works.

        • 1. Re: Change resolution of framebuffer/TTY
          La_Poutine_ Lurker

          I had the same issue, and right now I set the HW compatibility settings of the VM to 10 as a workaround.  Anything higher seems to cause the issue mentioned above.

           

          Anyone who can reply to this thread with a permanent solution while using a compatibility setting of 11 and higher would be greatly appreciated. 

           

          Thx !