1 2 Previous Next 15 Replies Latest reply on Feb 10, 2019 4:51 PM by nettech1

    Users getting randomly disconnected

    vols2 Novice

      Hi

       

      We are using Horizon 7.6 with instant clones desktop pool and some users have reported that they have been getting disconnected. issue seems to happen randomly. Not all users get disconnected at the same time. Going through the logs i found this error message

      Application launch failed, exception was: The agent returned an error response [ERROR-CODE=AGENT_ERR_LOGOFF_IN_PROGRESS]

       

      Could the agent be the cause of users getting randomly disconnected

        • 1. Re: Users getting randomly disconnected
          nettech1 Hot Shot

          Are users local or remote? What client are they using to connect?

          Can you share the relevant portion of the Agent and Client logs ?

          Did you capture the logs using the vdmadmin from the connection server?

           

          Thanks

          • 2. Re: Users getting randomly disconnected
            vols2 Novice

            Hi Nettech

             

            users are using HP thin clients to connect. Just to add I connected to the connection server using microsoft remote desktop and also got disconnected for a couple of seconds

             

            this is another error msg from the logs, is java causing the disconnection issue

            Reported error:Secure connection lost... shutting down.:

            caused by... com.vmware.vdi.logger.Logger.error(Logger.java:92)

            com.vmware.vdi.ob.tunnelservice.bf: Tunnel session lost

            at com.vmware.vdi.ob.tunnelservice.bw.a(SourceFile:577)

            at com.vmware.vdi.ob.tunnelservice.bz.run(SourceFile:962)

            at java.lang.Thread.run(Thread.java:748)

            • 3. Re: Users getting randomly disconnected
              vols2 Novice

              e.g. of a user who was disconnected

              2019-02-04T10:05:32.377+12:00 INFO  (0E28-0780) <SimpleDeamonThread> [g] (Request75) User S11169287 connected to the Secure Gateway Server - session ID: 7C69_***_3DA4

              2019-02-04T10:05:32.775+12:00 INFO  (0C28-0854) <DesktopControlJMS> [Audit] DISCONNECTED:Server:cn=89c5a263-3f66-4c39-a8d9-ae65e32ab96a,ou=servers,dc=vdi,dc=vmware,dc=int;Pool:cn=libfoyervdi,ou=server groups,dc=vdi,dc=vmware,dc=int;DNS:LibraryVDIVM-9;IP:144.120.148.23;IP6:null;USER:STUDENT\S11169287;USERDN:cn=s-1-5-21-220523388-682003330-1177238915-355384,cn=foreignsecurityprincipals,dc=vdi,dc=vmware,dc=int;BROKERUSERSID:S-1-5-21-220523388-682003330-1177238915-355384;

              2019-02-04T10:05:32.775+12:00 INFO  (0C28-0854) <DesktopControlJMS> [DesktopTracker] User STUDENT\S11169287 disconnected from machine LibraryVDIVM-9 for desktop libfoyervdi - session allocated at February 4, 2019 9:39:13 AM, connected for 7 mins 47 secs

               

              2019-02-04T10:05:33.077+12:00 INFO  (0C28-0854) <DesktopControlJMS> [Audit] PENDING:Server:cn=89c5a263-3f66-4c39-a8d9-ae65e32ab96a,ou=servers,dc=vdi,dc=vmware,dc=int;Pool:cn=libfoyervdi,ou=server groups,dc=vdi,dc=vmware,dc=int;DNS:LibraryVDIVM-9;IP:144.120.148.23;IP6:null;USER:STUDENT\S11169287;USERDN:cn=s-1-5-21-220523388-682003330-1177238915-355384,cn=foreignsecurityprincipals,dc=vdi,dc=vmware,dc=int;BROKERUSERSID:S-1-5-21-220523388-682003330-1177238915-355384;

              2019-02-04T10:05:34.599+12:00 INFO  (0C28-0854) <DesktopControlJMS> [Audit] RECONNECTED:Server:cn=89c5a263-3f66-4c39-a8d9-ae65e32ab96a,ou=servers,dc=vdi,dc=vmware,dc=int;Pool:cn=libfoyervdi,ou=server groups,dc=vdi,dc=vmware,dc=int;DNS:LibraryVDIVM-9.student.usp.ac.fj;IP:144.120.148.23;IP6:null;USER:STUDENT\S11169287;USERDN:cn=s-1-5-21-220523388-682003330-1177238915-355384,cn=foreignsecurityprincipals,dc=vdi,dc=vmware,dc=int;BROKERUSERSID:S-1-5-21-220523388-682003330-1177238915-355384;

              2019-02-04T10:05:34.599+12:00 INFO  (0C28-0854) <DesktopControlJMS> [DesktopTracker] User STUDENT\S11169287 reconnected to machine LibraryVDIVM-9 for desktop libfoyervdi - session allocated at February 4, 2019 9:39:13 AM FJT, disconnected for 0 mins 4 secs

              • 4. Re: Users getting randomly disconnected
                nettech1 Hot Shot

                So users are local, you don't have a Security Server / Access Point / UAG in your implementation? What is the model of your HP thin client?

                Are you connecting using Blast / PCoIP or RDP ? What version of the horizon agent is installed on your instant clones?

                 

                Are the thin clients in he same vlan with your connection server and the VMs? Is there a load balancer along the path?

                 

                Can you take a wireshark trace of your VDI session and examine the errors around the disconnect time? Wondering if the disconnects are related to the network configuration and not Horizon agent / client ?

                • 5. Re: Users getting randomly disconnected
                  vols2 Novice

                  Hi

                  We use HP T630 thin clients, use blast as the display protocol and the agent is 7.6, the thin clients and the connection server is n the same vlan while the vm's are on another vlan. We are just using ESXI 6.5ui and Vcenter with the connection server as it is for student use in one of our labs. It has been working really well for the last 8 months. We were using Horizon 7.3 and then upgraded to Horizon 7.6 last week when the issue started happening

                  • 6. Re: Users getting randomly disconnected
                    nettech1 Hot Shot

                    Anything in the logs of the Thin client about the disconnects?

                    Are you running Windows or Linux on the thin clients?

                    • 7. Re: Users getting randomly disconnected
                      vols2 Novice

                      ws1.jpg
                      Hi

                      Was running wireshark on the VM"s Vlan and from the image when VM12 got disconnected it was showing the 169 IP instead of 144. We have 2 servers with the same config and only one is getting disconnected when users connect to the VM on that server. Any thoughts on what might be the issue

                      • 8. Re: Users getting randomly disconnected
                        sjesse Expert

                        What are the least times in the dhcp range, could they be expiring, and not renewing.

                        • 9. Re: Users getting randomly disconnected
                          vols2 Novice

                          Hi Sjesse

                           

                          DHCP pool is fine. We have 2 connection servers and 50 thin clients in one vlan and all 60 win 10 vms in another vlan. It only happens to users who connect to the first server's desktop pool and use the vm"s in that pool. The second server and the vm"s on that desktop pool work normally . Could it be an agent issue. Not all users get disconnected at the same time, only  2 or 3 will get disconnected.

                          • 10. Re: Users getting randomly disconnected
                            sjesse Expert

                            How many hosts do you have, could they be moved, and then lose the connection. The agent wouldn't cause a 169 address, losing the actualy network connection would. Instant clones I think if its off for ahwile the delete them and create new ones.

                            • 11. Re: Users getting randomly disconnected
                              vols2 Novice

                              we have 2 hosts, connection server on each host with their own desktop pools. It's only happening on one server, the connection server was on Horizon 7.3 and we did an in-place upgrade to Horizon 7.6 following the steps in the vmware documentation of upgrading the connection server first then the agent on the golden image. On the golden image do we have to remove the old agent first or we can just install the new agent over the old one to upgrade

                              • 12. Re: Users getting randomly disconnected
                                nettech1 Hot Shot

                                Wireshark on the VM's vlan would not capture the traffic between the VM and the Thin client. You are only seeing broadcast and multicast packets.

                                 

                                You need to capture unicast between the virtual desktop and your thin client.

                                 

                                what nics are you using in the VMs? E1000 or VMXNET3?

                                what version of VMWare tools is installed in the instant clones ?

                                 

                                Please check the event logs on the virtual desktop for event ID 10400

                                 

                                vmxnet3 NIC Resetting

                                The network interface 'vmxnet3 Ethernet Adapter has begun resetting. There will be a momentary disruption in network connectivity while the hardware resets. Event ID 10400

                                • 13. Re: Users getting randomly disconnected
                                  vols2 Novice

                                  using vmxnet nic, vmware  tools version 10287 (10.1.15) installed on the instant clones

                                  • 14. Re: Users getting randomly disconnected
                                    BenFB Expert

                                    We had a similar issue with Wyse thin clients at a branch office. The devices were renewing their DHCP leases at the same time which overwhelmed the DHCP server which was running on a router. This resulted in the renewal failing which would disconnect the session when the thin client no longer had an ip address.

                                    1 2 Previous Next