1 2 Previous Next 25 Replies Latest reply on Aug 20, 2019 1:39 PM by pbastiaans

    Visio 2016 - Keeps running Office 2016 configuration

    pbastiaans Novice

      To create this app stack:

      1. Downloaded Visio 2016 VL from MS VLSC (verified it is not retail version)
      2. Followed instructions from here to build Office 2016 on the ref image: VMware Knowledge Base
      3. Created a new app stack on this ref image VM, using the Visio 2016 MSI installer previously downloaded.
      4. Ran cscript.exe ospp.vbs /rearm

      I get the Office setup, whenever this Visio 2016 app stack is assigned.

       

      As part of troubleshooting I have:

      • Run the Office 2016 repair while provisioning
      • Run the Office 2016 and Visio 2016 repair during provisioning
      • Created the app stack on a 'vanilla' VM without Office 2016 suite
        • 2. Re: Visio 2016 - Keeps running Office 2016 configuration
          rcscott44 Novice

          I have the same issue.  Running AppVolumes 2.15, Office 2016 Pro+ on the golden image of Win10 LTSC 2019 instant clone pool (Horizon 7.7)

           

          Capture machine is a clean build of Win10 LTSC 2019. and have used the VMware Knowledge Base for the capture.  Trying to capture Visio 2016 Pro and Project 2016 Pro.

           

          I have tried installing with Office 2016 Pro+ on the provisioning machine and without it.  Both seem to capture with no issues.  But, when attaching to the instant clone, it launched into set-up and then fails with "can't find necessary file" type errors.  If I close Visio, wait for set-up to revert itself and stop, I can re-open Visio and be functional, but it will not activate and de-activates Office 2016 Pro.

           

          I have tried capturing the AppStack off the golden image for the instant clone pool, but the Visio installation fails to run with the same missing files errors.

           

          Lastly, we use Active Directory-Based Authentication, not KMS server.  Does anyone know if an actual KMS server is required?  ADBA authenticates Visio 2016 Pro as a non-AppStack install just fine.

           

          From the instant clone Application event logs, I can see install errors involving language packs, but both Office and Visio are configured with the exact same settings (Install All from Desktop).

          • 3. Re: Visio 2016 - Keeps running Office 2016 configuration
            pbastiaans Novice

            We're not on Win 10 yet...that's coming in the next few months.

             

            The only suggestion I have is:

            - Clone the reference image you publish to the pool

            - Remove the Horizon agent/UEM Agent

            - use this as your provisioning device

             

            I have not been able to create an app stack of Visio 2016 (MSI Install). Period. VMWare support has been horrible. To the point one tech told me to exclude \program files (x86\microsoft office in snapvol.cfg

            • 4. Re: Visio 2016 - Keeps running Office 2016 configuration
              rcscott44 Novice

              I tried that exact method.  I cloned my golden image, renamed, removed App Volumes, Horizon, UEM, and VM Tools.  I then re-installed AppVolumes only and took a snapshot.  When I tries to create a new App Stack and use the clone for provisioning, App Volumes saw the clone as available and allowed me to use it to provision.  However, when I logged onto the clone, the AppVolumes Agent never ran and I got no window saying that AppVolumes was capturing.

              • 5. Re: Visio 2016 - Keeps running Office 2016 configuration
                Ray_handels Master
                Community WarriorsvExpert

                Just out of curiosity. Do you have Office itself (I know, Visio is part of Office, old school admin here ) installed on the golden image?

                If you do have it installed there there is no need to rearm Visio during packaging, it sill use the Office "license" on the GI for as far as I know.

                • 6. Re: Visio 2016 - Keeps running Office 2016 configuration
                  pbastiaans Novice

                  VMware is suggesting this issue is resolved with app vol 2.14...where's that grain of salt?

                  • 7. Re: Visio 2016 - Keeps running Office 2016 configuration
                    Ray_handels Master
                    vExpertCommunity Warriors
                    VMware is suggesting this issue is resolved with app vol 2.14...where's that grain of salt?

                    What version are you using now?

                    And to be honest (and believe me I have seen my fair share of Appvolumes versions) the 2.14.2 version has been one of the most stable versions VMWare made. 2.15 seems to be pretty decent as well apart from the packaging process that has some issues (not taking the February Microsoft Patch into account) when you need to reboot.

                     

                    We went from 2.14.2 to 2.15 without much of a hassle.. Versions seem to be more stable and stable as we go..

                    • 8. Re: Visio 2016 - Keeps running Office 2016 configuration
                      rcscott44 Novice

                      We are AppVolumes 2.15.  We upgraded about a month ago from 2.14.2 because we are deploying Win10 LTSC 2019 for our instant clones.

                       

                      Additional info:  when I use a provisioning machine that was cloned from our golden image (remove Horizon and Uem, reinstall AppVolumes last)  The installer fails with the generic can't find file error, with no code or idea of failing file during the capture.  However, I can run the install on that provisioning machine natively when not capturing.

                      • 9. Re: Visio 2016 - Keeps running Office 2016 configuration
                        Ray_handels Master
                        vExpertCommunity Warriors
                        Additional info:  when I use a provisioning machine that was cloned from our golden image (remove Horizon and Uem, reinstall AppVolumes last)  The installer fails with the generic can't find file error, with no code or idea of failing file during the capture.  However, I can run the install on that provisioning machine natively when not capturing.

                        That seems to be the February patch issue.

                        • 10. Re: Visio 2016 - Keeps running Office 2016 configuration
                          jmatz135 Hot Shot

                          Are you using MSI installers for the Office and Visio install or Click-to-Run?  You can't mix and match as far as I know.

                           

                          I have MS Office 365 installed in an appstack installed with the click-to-run package with this config:

                           

                          <Configuration>

                               <Add OfficeClientEdition="32" Channel="Broad" Version="16.0.10730.20264">

                                    <Product ID="O365ProPlusRetail">

                                         <Language ID="en-us" />

                                   </Product>

                               </Add>

                          <Updates Enabled="FALSE" UpdatePath=""/>

                          <Display Level="Full" AcceptEULA="TRUE" />

                          <Property Name="PinIconsToTaskbar" Value="FALSE"/>

                          <Property Name="SharedComputerLicensing" Value="1" />

                          <Logging Level="Standard" Path="%programdata%\Appdeploy\Office2016" />

                          </Configuration>

                           

                          This was done on a clean provisioning machine.  Then on the same clean provisioning machine i.e. without the Office suite installed I captured Visio using the same Click-To-Run package but used this config:

                           

                          <Configuration>

                               <Add OfficeClientEdition="32" Channel="Broad" Version="16.0.10730.20264">

                                   <Product ID="VisioProXVolume" PIDKEY="My Volume License Key">

                                          <Language ID="en-us" />

                                   </Product>

                               </Add>

                          <Updates Enabled="FALSE" UpdatePath=""/>

                          <Display Level="Full" AcceptEULA="TRUE" />

                          <Property Name="PinIconsToTaskbar" Value="FALSE"/>

                          <!--<Property Name="SharedComputerLicensing" Value="1" /> -->

                          <Logging Level="Standard" Path="%programdata%\Appdeploy\Office2016" />

                          </Configuration>

                           

                          This seems to work except for Visio attachments won't open directly from Outlook.  Haven't seen any other issues though.

                          • 11. Re: Visio 2016 - Keeps running Office 2016 configuration
                            pbastiaans Novice

                            MSI Install. Support says upgrade to 2.14, taking that advice with a shaker full of salt.

                            • 12. Re: Visio 2016 - Keeps running Office 2016 configuration
                              rcscott44 Novice

                              We are also using MSI install for all applications, no O-365.

                               

                              Part of our problem has been resolved.  Our provisioning machine did have the Feb'19 MS update and was blocking the MSI install when provisioning.  I removed the KB and was able to successfully provision a working AppStack for Visio and Project 2016.  I used a clone of the Desktop Pool's golden image (minus Horizon and UEM agents) and it all worked fine.  

                               

                              The last issue I have is that the Visio and Project applications will not activate.  They do activate when installed on a base image, or stand-alone PC.  Office on our base image activates without issue, but the AppStack does not not.

                               

                              -Bob

                              • 13. Re: Visio 2016 - Keeps running Office 2016 configuration
                                pbastiaans Novice

                                Thank you Ray - Possible to get that KB number?

                                • 14. Re: Visio 2016 - Keeps running Office 2016 configuration
                                  pbastiaans Novice

                                  Bob

                                   

                                  Do you have Office on your golden?

                                   

                                  License activation, I have found these commands helpful (apologies if preaching to the choir)...

                                   

                                  Check activation status..

                                  cscript.exe ospp.vbs /dstatus

                                  Check activation status all (found hidden stuff this way)...

                                  cscript.exe ospp.vbs /dstatusall

                                  Activates (this can also be added to app vol bat file or UEM to force)...

                                  cscript.exe ospp.vbs /act

                                  List KMS Server (we found a server had come up as a KMS server, which slowed/broke activation)...

                                  cscript slmgr.vbs /dlv

                                  1 2 Previous Next