1 Reply Latest reply on Feb 4, 2019 11:11 AM by tunemickyJP

    Cannot deploy IE8 32bit captured from WinXP X86

    superwizard_cn Lurker

      I see blog(https://blogs.vmware.com/thinapp/2015/01/package-internet-explorer-8.html) and video https://www.youtube.com/watch?v=5OXlH8Kqi2I

       

      Now I have:

      -- Windows XP X86(Chinese simplied) with native Internet Explorer 6 32bit

      -- IEShims.dll and JSProxy.dll from a Windows 7 32bit with Internet Explorer 8 32bit

      -- Internet Explorer standalone installer (IE8-WindowsXP-x86-CHS.exe)

       

      I installed Thinapp 5.2.0 on the Windows XP. I am sure I followed ThinApp User's Guide, I just kept all default settings at all steps(entry points, group authorized, full write access to non-system .......). But before "build project", I applied the IEShims.dll to ProjectFolderPath\%ProgramFilesDir%\Internet Explorer, and JSProxy.dll to ProjectFolderPath\%SystemSystem%, then the project was built.

       

      As described in kb2069870(https://kb.vmware.com/s/article/2069870) below:

      Internet Explorer 8

      ........

      Can be deployed to Windows Vista to 10.

      Can also be deployed to 64-bit Windows 7 SP1.

      ........

       

      I tried deploying the captured IE8 to a Windows 10 X86, and a Windows 7 SP1 X64, but neither of them succeeded. It was launched and IE window was popped out, but it didn't run correctly, and all menu items were unavailable.

       

      Is there anything wrong?

       

      Thanks & regards,

      Jie