1 Reply Latest reply on Jan 19, 2019 5:50 AM by vmrale

    Pre-Upgrade Checks failing 6.5U2c to 6.7U1

    Marco_2_G Novice

      Hello everyone

       

      I am having the issue that pre-upgrade checks are failing upon trying to upgrade an external PSC.

       

      As in this case: 6.5U2c > 6.7U1 Pre-Upgrade Check Failed

       

      I am getting Cannot validate target appliance configuration as not enough information from the source appliance can be collected. For more details check out the server logs

       

      However, this is a fresh installation. I have setup a lab environment with two PSCs and two vCenters in enhanced linked mode.

       

      This happens when I try to upgrade the first PSC.

       

      I thought perhaps I have to converge them to an embedded PSC first, but that doesn't work either. When I put the FQDN of the vcenter in the JSON, it tells me it cannot resolve to hostname. The hostname is pingable though.

       

      When I switch over to an IP instead, I get a script error missing double quote.

       

      This was on 6.7 iso.

       

      I then thought perhaps I need to use the convergence script from 6.5 but here I am told that the version of the iso does not correspond to the vcenter. That is true as I upgraded the PSCs and vCenters after installation to the latest 6.5 release.

       

      However there is no iso file for that build number as far as I know.

       

      So can somebody tell me what the correct method of moving from external 6.5U2 enhanced linked mode to embedded 6.7U1 enhanced linked mode is?

       

      I will attach the logs from my update attempt through the UI.

       

      Thank you for any help you can provide.

       

      Regards,

       

      Marco