2 Replies Latest reply on May 13, 2019 8:11 PM by Sri_KSK

    Failed to query ip address error message

    Erilliot Novice

      Hello everyone,

      I am currently having a pressing issue when deploying vmware inegrated openstack version 5.1 as i am using it for my thesis. The problem is after populating the required deployment fields and going ahead with the deployment, it fails to deploy and gets stuck at the waiting for IP stage (please see attached screenshot) after which it fails and returns a  failed to query ip message. Please has anyone encountered this and possibly has a solution. I will appreciate as this is from my thesis and thus, the urgency.

      Thank you.

      VIO.png

        • 1. Re: Failed to query ip address error message
          Erilliot Novice

          Screenshot (57).pngthats the log file for anyone who may need it to help

          • 2. Re: Failed to query ip address error message
            Sri_KSK Lurker

            Hi Erilliot,

             

            I am also facing the same error, built my environment in lab with minimum resources. Tried deploying multiple times, but facing same error.

            DId you found any solution for this issue ?

             

            Seems there are no VIO experts out there, cannot find any solutions online / VMware KB's & communities.

             

            Found this is a knwon error to VMware and provided Solution in multiplt versions releases and still it repeats.

             

            VMware Integrated OpenStack 2.0 Beta Release Notes

            VMware Integrated OpenStack 2.5.1 Release Notes

             

            Deployment fails with Failed to query IP address error.
            This failure occurs primarily in slow environments and might in some cases be related to Ubuntu bug 1326199. This issue is fast-tracked for resolution.

            Workaround: You work around this issue by modifying the rootdelay=180 parameter setting in the /boot/grub/menu.lst file.

            1. Remove the snapshot of the VMware Integrated OpenStack template VM.
            2. Start the VMware Integrated OpenStack template VM.
            3. Using SSH, log in to the template VM CLI.
            4. Open the /boot/grub/menu.lst file in a text editor.
            5. Add the rootdelay=180 parameter to line 135.
            6. Save the /boot/grub/menu.lst file.
            7. Clear all contents from /etc/network/interfaces directory.
            8. Stop the VMware Integrated OpenStack template VM.
            9. In vCenter, delete the failed deployment.
            10. Redeploy VMware Integrated OpenStack.