6 Replies Latest reply on Jan 10, 2019 4:17 AM by LucD

    View API Request Timeout

    vBrain14 Lurker

      Hello,

       

       

      I try using the View API method "ADUserOrGroup_GetInfos" but I get this error message.

       

      Exception calling "ADUserOrGroup_GetInfos" with "1" argument(s): "The request channel timed out while waiting for a reply 
      after 00:01:39.9899955. Increase the timeout value passed to the
      call to Request or increase the SendTimeout value on the Binding.
      The time allotted to this operation may have been a portion of a longer timeout."
      At C:\Users\T06122B\git\temp\VDItoSAPSync.ps1:44 char:9
      +         $allusers = $services.ADUserOrGroup.ADUserOrGroup_GetInfos($a ...
      +         ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
          + CategoryInfo          : NotSpecified: (:) [], MethodInvocationException
          + FullyQualifiedErrorId : TimeoutException
      

       

      where can I increase the timeout for API calls?

       

       

      Edit: Formating ErrorMessage

        • 1. Re: View API Request Timeout
          LucD Guru
          Community WarriorsUser ModeratorsvExpert

          Which PowerCLI version are you using?
          There have been similar reports with older PowerCLI versions.

          See for example Connect-HVserver error

          • 2. Re: View API Request Timeout
            LucD Guru
            vExpertUser ModeratorsCommunity Warriors

            You might try the GlobalSettings_Update method to increase the timeout value.

            Have a look at the properties in the GlobalSettingsInfo - General Data object.

            • 3. Re: View API Request Timeout
              vBrain14 Lurker

              I Use:

               

              Powercli

              VMware.Vim                          6.7.0.10334489
              VMware.VimAutomation.Cis.Core       11.0.0.10335701
              VMware.VimAutomation.Common         11.0.0.10334497
              VMware.VimAutomation.Core           11.0.0.10336080
              VMware.VimAutomation.HorizonView    7.6.0.10230451
              

               

              with this PowerCliConfiguration:

               

              Scope    ProxyPolicy     DefaultVIServerMode InvalidCertificateAction  DisplayDeprecationWarnings WebOperationTimeout
                                                                                                                Seconds
              -----    -----------     ------------------- ------------------------  -------------------------- -------------------
              Session  UseSystemProxy  Multiple            Unset                     True                       300
              User
              AllUsers
              

               

              and this GlobalConfig.GeneralData

               

              ClientMaxSessionTimePolicy       : TIMEOUT_AFTER
              ClientMaxSessionTimeMinutes      : 10080
              ClientIdleSessionTimeoutPolicy   : TIMEOUT_AFTER
              ClientIdleSessionTimeoutMinutes  : 4
              ClientSessionTimeoutMinutes      : 1200
              DesktopSSOTimeoutPolicy          : DISABLE_AFTER
              DesktopSSOTimeoutMinutes         : 4
              ApplicationSSOTimeoutPolicy      : ALWAYS_ENABLED
              ApplicationSSOTimeoutMinutes     :
              ViewAPISessionTimeoutMinutes     : 10
              PreLoginMessage                  : 
              DisplayWarningBeforeForcedLogoff : True
              ForcedLogoffTimeoutMinutes       : 5
              ForcedLogoffMessage              : 
              EnableServerInSingleUserMode     : False
              StoreCALOnBroker                 : False
              StoreCALOnClient                 : False
              EnableUIUsernameCaching          : True
              ConsoleSessionTimeoutMinutes     : 180
              

               

               

              I have not found a setting here that matches the timeout from my error message.

               

              In my opinion, the set timeouts are higher than the timeout in the error message of 00:01:39.9899955

              • 4. Re: View API Request Timeout
                LucD Guru
                Community WarriorsUser ModeratorsvExpert

                I know the value doesn't correspond, but did you already try increasing the 5 min weboperations timeout?

                There was a similar message for a failing Move-VM that apparently was fixed by increasing the 300 value.

                See Re: Move-VM The request channel timed out while waiting for a reply after 00:05:00

                • 5. Re: View API Request Timeout
                  vBrain14 Lurker

                  i set the timeout for the session to 3600. unfortunately, the result is the same.

                   

                  Scope    ProxyPolicy     DefaultVIServerMode InvalidCertificateAction  DisplayDeprecationWarnings WebOperationTimeout
                                                                                                                    Seconds
                  -----    -----------     ------------------- ------------------------  -------------------------- -------------------
                  Session  UseSystemProxy  Multiple            Unset                     True                       3600
                  User
                  AllUsers
                  
                  • 6. Re: View API Request Timeout
                    LucD Guru
                    User ModeratorsCommunity WarriorsvExpert

                    I don't really have any clues what might be causing this.
                    I would suggest to open a SR.