7 Replies Latest reply on Jan 8, 2019 2:21 AM by Ray_handels

    Program install fails during provisioning

    JohnFLi Novice

      running VMware AppVolumes v2.14.

       

      I have a vm of Windows 10 (v1809)  that is nice and clean, except I have the AppVol agent on it as this machine is used for provisioning.

      There is an application (bartender 9.3) that I need to create an app stack for.

       

      i start to the provisioning on the app vol machine, and on the Win10 machine, when the little appvol box pops up, I start the install for Bartender.

      Install goes without issue.  It fails upon starting the program with a 'side-by-side' error.

      yet if I revert to the clean snapshot (appvol agent is still installed but I did not start provisoning) teh program installs and runs just fine.

       

      Any ideas?

        • 1. Re: Program install fails during provisioning
          JohnFLi Novice

          Also, I tried installing Bartender during the provisioning process and completed it as normal.

          Assigned teh app stack.    THe user that it was assigned to gets teh same error:

           

           

          Activation context generation failed for "C:\Program Files (x86)\Seagull\BarTender Suite\bartend.exe". Dependent Assembly Microsoft.VC80.MFC,processorArchitecture="x86",publicKeyToken="1fc8b3b9a1e18e3b",type="win32",version="8.0.50727.762" could not be found.

          • 2. Re: Program install fails during provisioning
            Lakshman Virtuoso
            VMware Employees

            Windows 10 1809 build is not a supported client OS with 2.14 release. As per the install guide, 1803 is supported.

            https://docs.vmware.com/en/VMware-App-Volumes/2.14/App-Volumes-Install-Guide-2-14.pdf

            • 3. Re: Program install fails during provisioning
              Ray_handels Master
              Community Warriors

              Besides the fact that it is unsupported I would try and install all VC Redist versions (and at lest the one you are using now) on the golden image.

              Also, when creating a packaging machine I would suggest cloning the golden image and removing unnecessary software and agents (Horizon VIew agent and UEM agent being one of those) and package using that machine.

               

              Even though it is unsupported I think it should still work. This is just a VC Redist issue.

              • 4. Re: Program install fails during provisioning
                JohnFLi Novice

                Well, spent the day creating a Win10 1803 install.

                Much to my surprise, that after installing, it ran without issue with appVol running.

                 

                So i then applied the app Stack to a system, and it looked like all was good.

                 

                Issue now is, when clicking on it to run.....noting happens.

                so i tried running it as admin.....

                it gives me a window saying "This app has been blocked by your system administrator"

                Which is not the case.  There isn't any GPO that blocks this application.

                • 5. Re: Program install fails during provisioning
                  Ray_handels Master
                  Community Warriors

                  Could you please post a printscreen of the shortcut properties? Could it be that it points to a location where files cannot be stored within the appstack (%APPDATA% for example) or maybe a smart shortcut (or whatever it is called) in which it only point to the application name and not the actual executable?

                  • 6. Re: Program install fails during provisioning
                    JohnFLi Novice

                    the shortcut that it creates when clicking on the 'start' button points to c:\programdata\microsoft\windows\start menu\programs\bartender9.3    which i think is what you meant by a 'smart shortcut'

                     

                    the actual exe itself is in c:\program files (x86)\seagull\bartender suite.

                     

                    no matter which way i try it, it ignores me....(what am I married to this?   lol)

                     

                    what I did today was to create a new pool of machines (1803) and did NOT do the VMware OS Optimization Tool

                     

                    and now the app starts just fine.

                    • 7. Re: Program install fails during provisioning
                      Ray_handels Master
                      Community Warriors

                      My guess is that it is not the application that fails but mostly my guess is that there is an issue with a service being disabled by OSOT or a task being removed.

                      If it does work without running OSOT I would suggest looking into OSOT and seeing which services are being disabled and when the application stops working.

                       

                      Looking the the vcredist it might well be the Windows Modules Instaler service that needs to be enabled (just wild guessing here though) but that's worth a shot.

                      I would not suggest going into production without at least having 70 to 80% of settings suggested by OSOT implemented. Windows 10 is quite "memory hungry" in comparison to W7...