10 Replies Latest reply on May 28, 2020 4:59 AM by DEMdev

    Upgrading from UEM 9.3 to 9.6

    harrymsg Novice

      Are there any backward compatibility issues with upgrading UEM to 9.6 and still having 9.3 on the linked clones temporarily until a scheduled golden image refresh?

        • 1. Re: Upgrading from UEM 9.3 to 9.6
          harrymsg Novice

          Followup:  Am I understanding correctly from the documentation that I need to upgrade the master image/linked clones to UEM 9.6 first, and then the console/share?

          • 2. Re: Upgrading from UEM 9.3 to 9.6
            VDINinja311 Enthusiast

            harrymsg

             

            Correct, update the agents first, then the console, then the ADMX templates and in that order. See Upgrade User Environment Manager .

             

            Don't forget about your UEM Application Profiler version on your Capture and Build machine.

            • 3. Re: Upgrading from UEM 9.3 to 9.6
              VDINinja311 Enthusiast

              Always a good resource: VMware Product Interoperability Matrices

               

              Just as an FYI we in the last few months upgraded from 9.2 directly to 9.5 and had no issues.

              • 4. Re: Upgrading from UEM 9.3 to 9.6
                DEMdev Master
                VMware Employees

                Hi harrymsg,

                 

                We strive to maintain backward compatibility across all UEM releases. Apart from very occasionally deprecating and (a few releases later) removing some minor functionality (which is always called out in the release notes), I'm not aware of any changes that affect backward compatibility.

                 

                As VDINinja311 stated, it's very important that you first upgrade the agent. It's fine to continue to use an "old" Management Console and "old" config files, as the agent will process that config perfectly fine. Switching to a newer Management Console ahead of an agent upgrade might result in config files referencing new functionality that the agent does not support yet, though.

                • 5. Re: Upgrading from UEM 9.3 to 9.6
                  DJKebab7 Lurker

                  The backwards compatibility is really quite impressive, I've just been working with a client running Immidio Flex Profiles 7 (which was before even Flex+), and I was able to do an in-place upgrade of the VMware UEM agent over the top of the old Immidio agent, and it was able to read the existing Flex 7 policies and profiles without issue (using the existing group policies). The UEM management console was also able to connect and read the old Flex 7 config.

                   

                  Some of the config entries (those built previously from built-in templates by the looks of it) asked to be "upgraded", this was the only point that things stopped working (I did this in test of course!), as once upgraded the old Immidio agents couldn't seem to read them. To be expected. But as long as you get all agents upgraded first, then the upgrade is very seamless, even from extremely old versions prior to the VMware acquisition.

                  • 6. Re: Upgrading from UEM 9.3 to 9.6
                    DEMdev Master
                    VMware Employees

                    Hi DJKebab7,

                     

                    Wow, Flex Profiles 7! That's been a while...

                     

                    Happy to hear that everything worked fine. And, indeed, the old-agent-can't-deal-with-new-settings behavior is as expected. In many cases we happen to be forward compatible as well, even though we do not make any guarantees about that. However, between Immidio Flex Profiles 7.x and VMware UEM 9.x a tiny bit too much has changed for that to work :-)

                    • 7. Re: Upgrading from UEM 9.3 to 9.6
                      manishbhatia26 Lurker

                      @harrymsg

                       

                      I am also planning to update UEM 9.4 to supported version. Please share your experience and challenges and things needs to take in while upgrading?

                       

                      I am planning to upgrade Management console first and later on in phases will update linked/instant clone. Will this approach work ? Or any Risk associated to it?

                      • 8. Re: Upgrading from UEM 9.3 to 9.6
                        DEMdev Master
                        VMware Employees

                        Hi manishbhatia26,

                        I am also planning to update UEM 9.4 to supported version. Please share your experience and challenges and things needs to take in while upgrading?

                        UEM/DEM updates are very straightforward.

                         

                        I am planning to upgrade Management console first and later on in phases will update linked/instant clone. Will this approach work ? Or any Risk associated to it?

                        That would be exactly the wrong way around. The only thing that really matters for an upgrade is that you upgrade the components in the correct order: first the agent, then the Management Console, and finally the ADMX templates.

                        • 9. Re: Upgrading from UEM 9.3 to 9.6
                          manishbhatia26 Lurker

                          Hi,

                           

                          Thanks for quick response.

                           

                          I updated flex engine 9.11 on one of the parent image and deployed on instant clone and it worked fine with Management console 9.4.  Will same work in vice-versa situation?

                           

                          Also i got below confirmation from Vmware that if management console is on higher version and additional feature are available on it. Till the agent/flex engine version is upgraded, you would not be able to leverage new featured on it. Same applies for scenario where flex engine is in higher version. All the existing features would continue to work.

                           

                          Also, we have Win7 VDI in environment, so wanted to check which version UEM is compatible to upgrade to support UEM policies on Win7.

                          • 10. Re: Upgrading from UEM 9.3 to 9.6
                            DEMdev Master
                            VMware Employees

                            Hi manishbhatia26,

                            I updated flex engine 9.11 on one of the parent image and deployed on instant clone and it worked fine with Management console 9.4.

                            Perfect, that's the supported scenario: "new" agents are backwards compatible with "old" Management Consoles.

                             

                            Will same work in vice-versa situation?

                            No, you must update the agent before the Management Console. That is the only supported approach.

                             

                            Also, we have Win7 VDI in environment, so wanted to check which version UEM is compatible to upgrade to support UEM policies on Win7.

                            There's no specific version of UEM/DEM you need for this; all of them support Windows 7.

                            1 person found this helpful