4 Replies Latest reply on Sep 7, 2019 9:47 AM by FenyX

    Turn off promiscuous mode in Win7 guest

    meterman70 Novice

      Host: Mac mini (Late 2012), 8GB RAM, 500GB HDD, macOS Mojave, Fusion 11.0.2

      Guest: Windows 7 Professional, all relevant patches / updates installed

      Network-related apps installed on guest: AVAST Antivirus

       

      For a while, I'd had issues with my Win7 VM being unable to access the internet.

       

      I recently determined I need to switch the network setting from NAT to Bridged, and which got the VM back online.

       

      Now, I have the message each time I boot up the VM - "A virtual machine is attempting to monitor all network traffic..."

       

      After doing some searching I found that the network is set up in 'promiscuous' mode... how do I turn this off?

        • 1. Re: Turn off promiscuous mode in Win7 guest
          wila Guru
          User ModeratorsCommunity WarriorsvExpert

          Hi,

           

          Sorry I don't have Windows 7 handy here atm, so don't have the exact steps, but if you have a network icon in the task bar, right click it and try some of the options.

          Eventually you should get here:

           

           

          The "Ethernet properties" in your windows 7 has a filter installed that switches your network adapter into promiscuous mode for capturing all the network traffic that passes your NIC.

          Uninstall that one.

           

          PS: If you're unsure then take a snapshot (or make a backup of your VM) before you start experimenting.

          --

          Wil

          | Author of Vimalin. The virtual machine Backup app for VMware Desktop Products
          | Vimalin : Automated backups for VMware Fusion and VMware Workstation Professional
          | More info at https://www.vimalin.com
          | Twitter @wilva
          | VMware Wiki at http://www.vi-toolkit.com
          • 2. Re: Turn off promiscuous mode in Win7 guest
            meterman70 Novice

            So, just for documentation's sake, in Win7, I go to:

             

            Control Panel -> All Control Panel Items -> Network and Sharing Center.

             

            Clicked on "Local Area Connection", then "Properties", bringing me to the dialog box you highlighted.

             

            I then unselected "Client for Microsoft Networks" and clicked OK, then Close.

             

            (my other options there are: QoS Packet Scheduler / File & Printer Sharing... / IP v6... / IP v4... / Link-Layer... I/O Driver / and Link Layer... Responder)

             

            Edit: it was still in promiscuous mode... trying again, I went to uninstall this line, and got a forced reboot. Still no joy. Guess I have to live with it.

            • 3. Re: Turn off promiscuous mode in Win7 guest
              wila Guru
              Community WarriorsUser ModeratorsvExpert

              Hi,

               

              You are in the area I was talking about, but none of the options you list are about putting a network adapter in promiscuous mode.

               

              Does the following link help?

              https://www.howtoguides.org/enable-promiscuous-mode-manually-in-windows-7

               

              --

              Wil

              | Author of Vimalin. The virtual machine Backup app for VMware Desktop Products
              | Vimalin : Automated backups for VMware Fusion and VMware Workstation Professional
              | More info at https://www.vimalin.com
              | Twitter @wilva
              | VMware Wiki at http://www.vi-toolkit.com
              • 4. Re: Turn off promiscuous mode in Win7 guest
                FenyX Lurker

                Hi wila.

                 

                I have the exact same issue but the link you shared instructs to enter a command that returns nothing on my side : netsh bridge show adapter. It's expected to get a NIC ID (number) in command response, here there's nothing but a blank line.

                 

                Still getting a warning message in VMWare Workstation each time I start my Win7 VM. I can't compare with other Windows versions as I only have Linux VMs in addition to that one. The message leads me to a vmware.com page where it's explained how to enable promiscuous mode but I'd like to disable it in the guest OS indeed, not enabling it.

                 

                Note that the VM's NIC is configured to Bridged Mode.

                 

                Any idea?