1 Reply Latest reply on Dec 31, 2018 5:21 AM by a.p.

    Problem with accessing datastore after RAID 0 changed to RAID 1....

    ClayGoss Novice

      I had a pair of 4 TB disks go south this week.  These are in a Dell R415 with 6/i PERC.  They were in a RAID 1.  One completely failed and the other was showing predicted failure.

       

      I ordered a pair of drives, put one in place of the failed one, but since they were not exactly the same, the rebuild failed.  So I popped all the drives, cleared the config, configured two RAID 0's with the "failing" drive in one and the new one in the other.  I copied all the VMs to the new datastore and got all VMs running.

       

      I then took the system down, popped all the drives, cleared the config, put the other new drive in and rebuilt the config as RAID 1.

       

      I will add here, there is a second RAID 1 of two 200 GB drives, which is the boot volume.

       

      Upon booting the system and connecting to vSphere client, I found that the 4 TB datastore was missing:

       

      Rescan All... did not show it.  I tried Add Storage > Disk/LUN and see this:

       

      I highlight "Local DELL Disk (naa...." and click next, then see this:

       

      I have tried a PERC reconfig, no change.  Logging into EXS using Putty and looking at devices shows:

       

      So, it appears my volume is there, but I cannot get it back as a datastore.

       

      Any ideas?

       

      Thank you!

      Clay Goss