2 Replies Latest reply on Dec 29, 2018 10:28 AM by lateralpass

    ssh accessibility to VM not working after static IP address was configured to IP address of removed VM

    lateralpass Lurker

      I have an ESXi host (version 6.0) with a VM running Debian that I use as a test server for web development. I was previously able to ssh into this machine with no issues. I decided to clean up a little and remove some VMs from disk that I wasn't going to be using anymore. One of which was a VM running Windows 2012. I wanted to use the statically assigned IP address the Windows 2012 VM was using to the Debian server.

       

      First I deleted the VM from disk. Then I went into my router and configured the static IP address. Then i went into my Debian VM and rebooted so DHCP would pull the new address (while writing this post I went in and statically configured the IP address in the debian machine's /etc/networking/interfaces file for good measure).  While I can't remember if my first attempted worked or not, at some point I wound up having to reboot the ESXi host and was able to ssh into the Debian VM.

       

      While working for a while though, the connection got lost and every subsequent attempt resulted in "Connection refused". I installed nmap on my Mac (the machine I work from) and the results didn't match the ufw (firewall) configs on my debian machine:

       

      wrongandrightt.png

       

      After rebooting the ESXi host again, I ran nmap and got these results:

       

      nmap_good.png

       

      When nmap returns these results I find that I'm able to SSH into my debian machine for a little while before it craps out again.

       

      The point of failure seems to be with my ESXi host, but I'm open to suggestions.