1 Reply Latest reply on Dec 26, 2018 3:25 PM by Billaboard

    xp on vmware unable to access local network

    Billaboard Lurker

      I have been using VMWare player for some time now on a Windows 7 64 bit machine to run 32-bit XP.  There have never been any problems connecting to the internet, but now I need to connect to the local Windows network, and specifically to two Linux backup machines that use samba. I can do this in two stages (backup to host, then backup to Linux m/c's separately), but this is awkward.

       

      I have tried:

      1. NAT and bridged network connections. Both connect to the internet, in NAT can ping the samba machines via their ip addresses, but cannot resolve their names. In bridged mode, I can't ping the Linux ip addresses.

      2. Tried setting WINS = Yes in samba (down by printer settings ie not as server). No difference.

      3. Tried a native XP machine on the network - it sees the whole network including the Linux machines.

      4. tried setting up a virtual W7 machine. I behaves more or less similarly to the XP VM.

       

      I am obviously missing something basic, but have spent over a day on this, including searches for answers without finding anything.

       

      Any suggestions gratefully received!

        • 1. Re: xp on vmware unable to access local network
          Billaboard Lurker

          OK, I've found a way to get this to work, but without any understanding of what I'm doing.

           

          I went into bridging mode, then in the virtual XP machine used the "Add a network place wizard", setting it to aim separately at the EXT4 and NTFS drives on the Linux machine by entering their network directory names. This brings up the drives as visible destinations in XP's "My network places".

           

          For some reason, after doing this, I can now ping the Linux machine from the command prompt. This definitely didn't work earlier in bridging mode.

           

          I can now set up the automatic backups, so the stress level has come back out of the danger zone. It woulld be nice to have an explanation of any of this, but I'm probably too old!