2 Replies Latest reply on Jan 7, 2019 1:41 AM by andreaspa

    Import OVF with .ISO not working

    andreaspa Enthusiast



      Trying to import an OVF which has .ISO files attached to it, and I can only click "Next" if I don't include the ISO, but then it will say that there's a file missing..



      This is without the ISO-file:


      Using, has anyone else encountered this problem?

      Will try to upgrade to tomorrow and see if that resolves the issue.



        • 1. Re: Import OVF with .ISO not working
          Jon Waite Enthusiast

          Not tried it, but I suspect this is working as designed - not sure import/export of OVFs with ISO's attached to the VM is meant to be supported.


          You can almost certainly get around it by:

          - Take a backup copy of all the files in case something goes wrong...

          - Edit the VDA01.ovf file with a text editor and remove the reference to the ISO file.

          - Delete the VDA01.mf file (since the manifest will contain a reference to the ISO).

          - Upload the VM OVF (without the ISO).


          You should then be able to separately upload the ISO to a catalog and re-attach it to the VM.

          • 2. Re: Import OVF with .ISO not working
            andreaspa Enthusiast



            My feedback here would be that if ISO uploads in OVF is not supported, then the dialog should be changed to reflect that, and allow an upload even without the ISO file and remove the references automatically. As it is now, users would just be confused on why it's not working.


            What I did to fix this was to use VMware converter to export everything, and then import it with ovftool, and that worked much better